Free plan cold start is very slow

It’s been like 20 minutes and it is still cold starting. Is this expected of the free plan?

EDIT: I gave up, then tried updating to Essentials plan, restarted the app in Settings, and the app shows this error:

503 Service Unavailable: No endpoints to handle the request. If you're the owner of this app, see this article for more information: (7)

I’m trying the GitHub Push to Deploy feature, and have not tried pushing via the CLI. Maybe that’s the issue?

I decided to try the meteor deploy command instead, and that finished after 10+ minutes. But it failed with

Error deploying application: Application is too large (maximum 367001600 bytes). Consider moving static assets to a separate
static hosting service.

How can I calculate locally how big the app is? My public folder is only 159MB, and app code is small compared to that. Where’s the rest? Does it include node_modules?

Your public folder sounds 159MB larger than it should be. “Public folder” comes from a pre-CDN era.

@paulishca The public folder is actually smaller than the limit in the error message. Is there something else? Does it look at the size of node_modules perhaps?

@trusktr Did you figure this out? I looked through my folder and noticed .meteor was massive.

.meteor folder is 3.2Gb
node_modules is 939Mb

I was looking at running GitHub - klaussner/meteor-cleaner: Clean up your Meteor package cache! but wanted to check if you solved your issue and how…

I never figured it out. I moved to NodeChef because it always works for a simple price, including with built-in production Mongo. I simply push to my repo, and NodeChef syncs from the repo, without needing to manage a separate Mongo service in any way. No settings.json fiddling required, it simply takes a default Meteor setup and wires it all up.

I do hope Galaxy will get back to this level of simplicity, so that we have healthy competition.