Galaxy Deployment Failure Despite Success Messages


#1

I’ve submitted a ticket but have yet to hear back. I’m following the steps from http://coderchronicles.org/2016/03/15/deploying-a-meteor-app-to-galaxy/ . I added oplog, but otherwise I followed the instructions to the word. Command window shows success, telling me my app is "now serving at " with the correct URL after having gone through all steps.

Except, I get “404 Not Found: No applications registered for host” when I visit the URL (and I have checked that my DNS is updated to correctly point at the ingress for meteor), and see no applications on my dashboard when logged in to Galaxy.

I have only the one meteor / galaxy account, so I’m certain I’m logged into the account I’m checking.

Anyone else run into this?


#2

Did you specify the correct path to settings.json?


#3

Yeah. Verified by modifying the “ROOT_URL” in the settings file to “http://www.domain.com” after initially having it “www.domain.com”. Without the http in the settings file, it says it’s now serving at www.domain.com, where with the http:// in the settings file, it’s saying now serving at http://www.domain.com.

I would imagine I would get a failure message if it was unable to find my settings file, rather than it appearing to be successful anyway?


#4

This is the command that worked for mine from mac terminal:

DEPLOY_HOSTNAME=galaxy.meteor.com meteor deploy www.mydomain.com --settings ./settings.json

And in my settings json at root of meteor app:

{ "galaxy.meteor.com": 
	{ "env": 
		{ "ROOT_URL": "http://www.mydomain.com", 
		   "MONGO_URL": "mongodb://<my mongo string>"} 
		}
 }

#5

Very similar to mine. I verified it was able to locate the settings file by giving it a fake filename instead. It failed to deploy with an error message. Tried removing oplog setting, same result. I’m at a bit of a loss. Considering Modulus.


#6

Back when I deployed my app, custom URLs had to be whitelisted, but supposedly that’s no longer required. Did you try deploying to meteorapp.com just to test?


#7

I haven’t, I didn’t want a trail of instances I needed to drop/destroy afterwards. Hoping someone in support can help figure it out faster than I can deploy elsewhere. I’m quite fond of the idea of deploying/hosting with the group behind the tech I’m using.


#8

When you say your command window shows success, do you mean you see a green dot in your Galaxy console? If so, the issue is almost certainly related to your DNS settings.

+1 to attempting to deploy to *.meteorapp.com - this will help determine if the issue in fact is with Galaxy.


#9

I just mean that the command console window, the window that appears when you type “cmd” into the command bar, shows a “Now serving at www.domain.com” after the meteor deploy is complete. No apps show in the Galaxy console/dashboard despite this.


#10

If you are not even seeing the app in your Galaxy console, then the app has not been associated with that account. Is it possible that you have more than one Meteor account? When you signed up for the Galaxy account, did you sign in first with your Meteor developer account?


#11

If I have two accounts, it’s due to some error on Galaxy’s/Meteor’s end. It would be especially troublesome as the second account shares my primary account password and username. (I don’t mean that to sound snarky at all, sorry, I just mean, I’d be shocked as it authenticated using the credentials I use for main account and am not aware of a second)


#12

I’m having the same issues on a meteorapp.com deploy.


#13

This often happens when DEPLOY_HOSTNAME=galaxy.meteor.com is not specified in the deployment command. Without that env variable, the deploy will target the Meteor.com free tier, hence you won’t see the app show up in the Galaxy dashboard.

If you are on Windows, the way to set this env variable and deploy is:
$ SET DEPLOY_HOSTNAME=galaxy.meteor.com
$ meteor deploy www.mydomain.com --settings ./settings.json

On all other OSes, this command works:

DEPLOY_HOSTNAME=galaxy.meteor.com meteor deploy www.mydomain.com --settings ./settings.json

Correct, there is no longer any need to whitelist a custom URL. You can deploy to www.yourdomain.com or subdomain.meteorapp.com, as long as no one else on Galaxy has taken that domain.


#14

Im also having the same issues as described above. is there any solution yet?