Getting Error: Module did not self-register


#1

Tried: npm update, npm rebuild, manually removed node_modules folder as well as rm -r node_modules then npm install or meteor npm install --save bcrypt, curl https://install.meteor.com/ | sh.

Also tried: xcode-select --install, rm -rf node_modules, npm cache clean, npm install.

Got: npm WARN package.json No README data and clang: warning: libstdc++ is deprecated; move to libc++ with a minimum deployment target of OS X 10.9 bcrypt@0.8.7 node_modules/bcrypt ├── bindings@1.2.1 └── nan@2.3.5

This is where I’m at now and still getting

> 20160927-16:14:50.718(-7)? [Error: Module did not self-register.]
> W20160927-16:14:50.948(-7)? (STDERR) js-bson: Failed to load c++ bson extension, using pure JS version

Node 4.5.0 / meteor 1.4.1.1 / mac os 10.11.6

If anyone has come up against this and has any ideas to pass along a fix, I’d greatly appreciate it. Thanks!

Incase this helps anyone else: I downgraded to Meteor 1.3.2.4 and all is fixed.


#2

Are you by chance using cfs:gridfs? If so see:


#3

Hello Hugh, that’s very helpful and a great link. I do have those cfs packages. I was messing around with collectionsfs, but turned out I didn’t need to use it. I will delete cfs:grids (and all the other cfs files I’m not using), and report back after removal. Thank you! Thank you!


#4

I deleted the cfs versions, but still can’t update my app and getting the same error as above. Bummer. Thanks Hugh. It was a great suggestion.


#5

Hi, did you have any success solving this in the end? I’ve just come across the same problem…


#6

Yes. I removed packages one-by-one to determine which had dependencies on collectionFS and cfs:grids. In my case, it was ryw:blog that I downloaded from atmosphere to fulfill the requirements of an assignment I was working on. When I removed ryw:blog, the error was gone. Hope that helps and gives you another plan to follow-up on to fix the problem.


#7

Thanks, will give it a go…