Getting error when building for iOS after installing "cordova-plugin-facebook-connect"

Hi, I’m getting this build error in iOS after installing the “cordova-plugin-facebook-connect” using the following command:

meteor add cordova:cordova-plugin-facebook-connect@3.2.0 
❯ meteor run ios --settings=private/settings.dev.json --port=3002
[[[[[ ~/Projects/kaged-muscle-trainer-app/kaged-muscle ]]]]]

=> Started proxy.
=> Started HMR server.
=> Meteor 2.6 is available. Update this project with 'meteor update'.
=> Started MongoDB.
   Installing Cordova plugins                [============         ] 57% 12.7s
[!] The `Kaged Muscle [Debug]` target overrides the `LD_RUNPATH_SEARCH_PATHS` build setting defined in `Pods/Target Support Files/Pods-Kaged Muscle/Pods-Kaged Muscle.debug.xcconfig'. This can lead to problems with the CocoaPods installation

[!] The `Kaged Muscle [Release]` target overrides the `LD_RUNPATH_SEARCH_PATHS` build setting defined in `Pods/Target Support Files/Pods-Kaged Muscle/Pods-Kaged Muscle.release.xcconfig'. This can lead to problems with the CocoaPods installation

[!] Your project does not explicitly specify the CocoaPods master specs repo. Since CDN is now used as the default, you may safely remove it from your repos directory via `pod repo remove master`. To suppress this warning please add `warn_for_unused_master_specs_repo => false` to your Podfile.

=> Errors executing Cordova commands:

   While preparing Cordova project for platform iOS:
   Error: ENOENT: no such file or directory, open 'package.json'
   at Object.openSync (fs.js:497:3)
   at Object.readFileSync (fs.js:393:35)
   at getPreferenceValue
   (/Users/mac/Projects/kaged-muscle-trainer-app/kaged-muscle/.meteor/local/cordova-build/plugins/cordova-plugin-facebook-connect/scripts/ios/after_prepare.js:28:30)
   at module.exports
   (/Users/mac/Projects/kaged-muscle-trainer-app/kaged-muscle/.meteor/local/cordova-build/plugins/cordova-plugin-facebook-connect/scripts/ios/after_prepare.js:38:33)
   at runScriptViaModuleLoader
   (/Users/mac/.meteor/packages/meteor-tool/.2.5.3.wa5a4n.vg1h++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/cordova-lib/src/hooks/HooksRunner.js:157:32)
   at runScript
   (/Users/mac/.meteor/packages/meteor-tool/.2.5.3.wa5a4n.vg1h++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/cordova-lib/src/hooks/HooksRunner.js:136:12)
   at
   /Users/mac/.meteor/packages/meteor-tool/.2.5.3.wa5a4n.vg1h++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/cordova-lib/src/hooks/HooksRunner.js:108:40
   at
   /Users/mac/.meteor/packages/meteor-tool/.2.5.3.wa5a4n.vg1h++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/meteor-promise/fiber_pool.js:43:40
   => awaited here:
   at Function.Promise.await
   (/Users/mac/.meteor/packages/meteor-tool/.2.5.3.wa5a4n.vg1h++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/meteor-promise/promise_server.js:56:12)
   at /tools/cordova/project.js:308:7
   at
   /Users/mac/.meteor/packages/meteor-tool/.2.5.3.wa5a4n.vg1h++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/meteor-promise/fiber_pool.js:43:40
   => awaited here:
   at Function.Promise.await
   (/Users/mac/.meteor/packages/meteor-tool/.2.5.3.wa5a4n.vg1h++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/meteor-promise/promise_server.js:56:12)
   at CordovaProject.runCommands (/tools/cordova/project.js:896:22)
   at CordovaProject.prepareForPlatform
   (/tools/cordova/project.js:306:10)
   at /tools/cordova/runner.js:86:29
   at Object.enterJob (/tools/utils/buildmessage.js:388:12)
   at CordovaRunner.prepareProject (/tools/cordova/runner.js:77:18)
   at /tools/runners/run-app.js:675:25
   at Object.capture (/tools/utils/buildmessage.js:283:5)
   at AppRunner._runOnce (/tools/runners/run-app.js:674:39)
   at AppRunner._fiber (/tools/runners/run-app.js:949:28)
   at /tools/runners/run-app.js:410:12

/Users/mac/.meteor/packages/meteor-tool/.2.5.3.wa5a4n.vg1h++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/meteor-promise/promise_server.js:218
      throw error;
      ^

Xcode version - 12.5
mac version - 11.2.2
Node version - v14.17.3
NPM version - 6.14.13
Meteor version - 2.5.3

You can reproduce this error by creating a fresh project with meteor and then add this plugin and try to build for iOS, you’ll see this error.

Please HELP