Gmail SMTP Less Secure App


#1

Hi there, I’ve spent a few hours today dealing with an email issue with Gmail. It wasn’t working after I initially set up GSuite with some new email addresses - I’d successfully set up the MAIL_URL with smtp and port 587 a while back with another email address that was being forwarded by Mailgun. So I went to into my GSuite Admin account and reconfigured IP whitelisting for Gmail SMTP Relay and it still wasn’t working - I continuously got the following error:

I20170819-19:17:32.783(-4)? Exception in defer callback: Error: Invalid login: 534-5.7.14 <https://accounts.google.com/signin/continue?sarp=1&scc=1&plt=AKgnsbvT
I20170819-19:17:32.784(-4)?     at Object.Future.wait ([redacted]/.meteor/packages/meteor-tool/.1.5.1.i81a94++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/server-lib/node_modules/fibers/future.js:449:15)
I20170819-19:17:32.786(-4)?     at Mail._syncSendMail (packages/meteor.js:209:22)
I20170819-19:17:32.788(-4)?     at smtpSend (packages/email.js:116:13)
I20170819-19:17:32.789(-4)?     at new Email.send (packages/email.js:174:5)
I20170819-19:17:32.791(-4)?     at Object.Email.send (packages/meteortoys_email.js:28:25)
I20170819-19:17:32.791(-4)?     at [redacted]
I20170819-19:17:32.795(-4)?     at [object Object].EVp.withValue (packages/meteor.js:1135:15)
I20170819-19:17:32.795(-4)?     at packages/meteor.js:452:25
I20170819-19:17:32.796(-4)?     at runWithEnvironment (packages/meteor.js:1189:24)
I20170819-19:17:32.797(-4)?     - - - - -
I20170819-19:17:32.798(-4)? 534-5.7.14 XWgdPSBi7cls88fHhjVtN_uMzqOUeg_QNmp8o8kewHbT7vq6UsOJpBFawHoejkC9YaVGOi
I20170819-19:17:32.799(-4)? 534-5.7.14 80fowbxs7XZ7PtlXDWBxxhzVkxshaoFspEquY4Va9vZauOc7itf7UUX2mNwVsv0OpG9fG_
I20170819-19:17:32.801(-4)? 534-5.7.14 q3Fj25RBwrQArwzLmLONShHwYoFhlUrSAoETLGyzYM1cgmVvDFVB03U_yiFYFMG6uDEIMy
I20170819-19:17:32.802(-4)? 534-5.7.14 8tek4FXUt7Qze75kKw4xPgPc2SMfU> Please log in via your web browser and
I20170819-19:17:32.808(-4)? 534-5.7.14 then try again.
I20170819-19:17:32.809(-4)? 534-5.7.14  Learn more at
I20170819-19:17:32.809(-4)? 534 5.7.14  https://support.google.com/mail/answer/78754 a64sm1443699qkb.0 - gsmtp

So after more Googling, I found this thread: https://stackoverflow.com/questions/20337040/gmail-smtp-debug-error-please-log-in-via-your-web-browser

Turns out I had to go into GSuite Admin and turn on Allow Less Secure Apps to authenticate via SMTP and then enable it in the individual email address account at https://www.google.com/settings/security/lesssecureapps

After making all of these changes it is now working. Does anyone have experience with this already? Is there any way to set up Meteor and the email package to make it “more secure” so that the “Allow Less Secure” configuration does not have to be switched on?

Thank you!