Google does not render my meteor website

I have successfully deployed my meteor website on amazon ec2. Website is available, but seems Google does not render the page when i try to search. I get “oops, looks like there’s no route on the client or the server for url meteor”, although the site is live and available.

I also tried Fetch as Google under Crawl menu in search console but i received the same response: “oops, looks like there’s no route on the client or the server for url meteor”.

I installed two packages: spiderable and prerenderio and added the following line in the head section:

In settings.json i added:
“PrerenderIO”: {
“token”: “my_registered_tooken_from_prerenderio”

Is there a way to make meteor website crawlable?

Have you tried testing how your site looks using’s pre-render testing server? You can find their instructions on how to do this here. If you already have your meteor app running locally you’ll want to make sure you change the default pre-render test server port to something other than 3000. Then add the PrerenderIO .prerenderServiceUrl option to your settings.json pointing to your pre-render test server.

Google now crawls javascript pages. Did you wait long enough to be referenced? A few days?

Yes, first i tested localy on port 3030. It showed the navigation bar and instead my home template, i got “oops, looks like there’s no route on the client or the server for url meteor”. Then i removed the prerenderServiceUrl from settings.json and deployed on ec2 with mup deploy. I have also installed the phantomjs on my server, but i still get this message “oops looks like…” when i try to crawl from search console.

The website is live and active for one week. Don’t know how long should i wait. This is the link:

On your site, I get

Uncaught ReferenceError: prerenderio is not defined

Also you should not install Spiderable + Prerender. You have to decide for one of both.

I removed the spiderable package, and the “prerenderio.set(‘prerenderToken’, ‘67QTVPGuDP2tK9rVFMKC’);” from Meteor.startup. I have only the configuration in settings.json:
“PrerenderIO”: {
“token”: “67QTVPGuDP2tK9rVFMKC”

I tried once again to crawl with webmasters tool but no success.

Even if i try to render a simple article from my web page ,
i get the same error. This indicates that Goggle does not crawl javascript pages. Any other idea?

Well, I can only tell you my setup. I’ve installed Spiderable on my server and used this package. Don’t forget to remove the original Spiderable and/or the Prerender package from your Meteor application.

If everything works fine, you should see a rendered page at