Google requires SDK 28 starting Nov 1st 2019

Below is from an email I just received from Google Play. Current meteor 1.8.1 is Android 27 … Does meteor provide ability to use Android 28 yet ? Looks like Google will block app updates unless SDK is at least 28

https://support.google.com/googleplay/android-developer/answer/113469#targetsdk


This is a reminder that starting November 1, 2019 , updates to apps and games on Google Play will be [required to target Android 9 (API level 28) or higher] After this date, the Play Console will prevent you from submitting new APKs with a targetSdkVersion less than 28.

Configuring your app to target a recent API level ensures that users benefit from significant security and performance improvements, while still allowing your app to run on older Android versions (down to the minSdkVersion).

Action required

Please ensure that your apps are configured to target at least Android 9 (API level 28) by November 1, 2019 .

5 Likes

See here:

you can see in commit 5e26ebb6a9d68cea176869ac3a83121dcee7e925 in the meteor repo the last time cordova-android and cordova-ios was updated the changes that were made, I kind of want to play around with my local repo of Meteor and see if bumping that up to the lastest and fixing any issues caused by that would get a apk file building for version 28 of the Android OS

mobile-config.js

App.setPreference('android-minSdkVersion', '22');
App.setPreference('android-targetSdkVersion', '28');