Help deploying my first Meteor app into a mobile app


#1

Hi, so today I decided to deploy into a webserver a project I have been working on for the last month, I followed this great Youtube video on how to deploy with Digital Ocean, Composer.io and the great tool MUP (https://www.youtube.com/watch?v=WLGdXtZMmiI). Everything went smoothly, I deployed it to the webserver and everything works as expected, but when I try running my app on an iOS mobile device using this command:

meteor run ios-device --mobile-server http://mydomain.com:81 (my actual port)

some strange things happen, like the fact that I can no longer use methods and the console in Xcode tells me that the methods were not foud, I don’t know if I did something wrong or if I need to add something or what else can I do. I was hoping that somebody on this great forum could point me in the right way.

This is the actual error that I see from Xcode:

Error: Error: Method not found [404]

and I see the error if I run the application on a physical device or on the simulator.

Thanks in advance!


#2

Is the same error displayed with a browser (did you try with just “meteor” and local access) or only with meteor run ?


#3

Thanks @lc3t35, If I open the app on the server http://mydomain.com:81 everything works fine, also if i run the app using meteor and connect it to my compose.io db everything works fine, maybe I have to build the app some other way? I even tried building it like:

MONGO_URL="MY MONGO URL" MONGO_OPLOG_URL="MY MONGO OPLOG URL" meteor build ~/directory/ --server=http://mydomain.com:81

but still no lock, the app still an’t use some methods, and the subscriptions look like they are never ready. Any ideas?


#4

Are you using facebook AppID or similar credentials ? Put them in a mobile-settings.json file like this
{
“public”: {
“version”: “0.x.x”
},

“facebook” : {
“AppID”: “xxxx”,
“AppSecret”: “zzzz”
}

“cordova”: {
“com.phonegap.plugins.facebookconnect”: {
“APP_ID”: “xxxx”,
“APP_NAME”: “yyy”
}
}
}
Then build with ----mobile-settings mobile-settings.json option


#5

Right now I’m not using any plugin that may need this credentials, and also I think that if the problem would be there then I wouldn’t be able to run it even on my localhost :s.


#6

We need to go inside your code -> I suggest some code review -> is it possible for you to process a request on https://www.airpair.com/help/request ? I or another expert should be able to help you for a few bucks, that should save you hours of painful searches.