Help test the release candidate for Meteor 1.1 - Windows and Meteor Version Solver


#1

Hello everyone!

We’ve been working hard on release 1.1, and we’ve got a release candidate for everyone to test! This release includes the new Meteor Version Solver and is the first official release that works on Linux, Mac, and Windows.

Run your app with meteor --release 1.1-rc.0 to test it out.

See the Release 1.1 issue on GitHub for more details.

Please try running your apps with the new release and let us know if there are any problems by commenting on the issue above. Thanks again to everyone who has been testing the Windows preview releases - we’re almost there!

Thanks,
Sashko, Slava, and Avi


#2

I’ll run a test for this in a few hours after my work demo. I know I’ve been having some issues with updating from 1.0.4.2 to 1.0.5 so I’m hoping 1.1-rc.0 will not be as problematic.


#3

Seems to work well.

I am under Windows. It didn’t work at first, by just using the new installer on top of the previous install. I had to uninstall the previous version, remove the .meteor folder in %LOCALAPPDATA%, then run the new installer.


#4

Wow, this has worked extremely well. I must say I’m impressed. So far, no issues of any kind.


#5

Hi brwn, it might a bit off-topic but what issues do you had with update 1.0.5? I am asking because I support the unofficial meteor universal bundler for arm boards and others. From my point of view there where just very few changes from 1.0.4.2 to 1.0.5. Thanks for a short note.


#6

The issues I was having involved Nitrous.io so I don’t know if they were specific to Meteor or Nitrous being screwy. I appeared to have the same issue with Meteor 1.1-rc.0 on Nitrous, but it works fine on my local box and in my deployed server. I would assume it’s a non-issue, although I did hear from others in the IRC room for Meteor that they were experiencing some very serious refresh/load times. I would direct you to ask on the channel.


#7

@sashko Thanks for the 1.1 release! I’m testing as we speak.


#8

Looks good so far. Smooth upgrade from 1.1-rc.0 :wink: very appreciative of this update, sir!


#9

Thanks! Hope it works for people!


#10

Sorry for asking something that may be dumb, but how exactly I run meteor on command line after I install it? It’s not on path:

meteor --help
’meteor’ is not recognized as an internal or external command,
operable program or batch file.

But I can run it inside the AppData\Local\.meteor folder (had to make a global search to find it).


#11

You need to restart your computer if you are on Windows 8.1. It says so in the last screen of the installer but it can be easy to miss. In a future version we hope to either make restarting unnecessary, or prompt to restart.


#12

And on Win7? :slight_smile:
20 chars


#13

On Win7 for some reason it just works! You still need to restart CMD though.


#14

Had to uninstall the WINDOWS-PREVIEW@0.3.0 first, then install. If I installed over it, I got some crazy output:

C:\Users\mmortal03\AppData\Local\.meteor\packages\meteor-tool\1.1.1\mt-os.window
s.x86_32\dev_bundle\lib\node_modules\fibers\future.js:245
                                                throw(ex);
                                                      ^
TypeError: Cannot convert null to object

And then a bunch more errors after that.


#15

That’s unfortunate! Hopefully it will not happen from now on. It might have been a bug in WINDOWS-PREVIEW@0.3.0


#16

Well, it didn’t work on my Win7. Gonna try to restart


#17

I am getting the same error as @gabrielhpugliese. Also on a Win 7 Enterprise SP1.

The Cmd Prompt does not recognize the meteor command. Any ideas on how to debug?


#18

I have rebooted and it worked.


#19

The latest Meteor update gave me this error (Windows 7):

C:\Users\Steve\Documents\Work\Meteor\myapp>meteor update

C:\Users\Steve\AppData\Local\.meteor\packages\meteor-tool\1.1.2\mt-os.windows.
x86_32\tools\files.js:643
      Console.debug(err);
      ^
ReferenceError: Console is not defined
    at Object._onImmediate (C:\Users\Steve\AppData\Local\.meteor\packages\mete
or-tool\1.1.2\mt-os.windows.x86_32\tools\files.js:643:7)
    at processImmediate [as _immediateCallback] (timers.js:354:15)

Running it a second time worked like a charm:

C:\Users\Steve\Documents\Work\Meteor\myapp>meteor update
myapp: updated to Meteor 1.1.0.2.

Changes to your project's package version selections from updating package
versions:

templates:forms  upgraded from 1.13.3 to 1.14.0