Help with Limiting my npm jQuery version to support Bootstrap


#1

I recently updated my project to Meteor 1.4 and I get the following error:

Uncaught Error: Bootstrap's JavaScript requires jQuery version 1.9.1 or higher, but lower than version 3

I had to use meteor npm install --save jquery but it gives me the error above because it installs jQuery v 3+. I did some research and found this thread: Bootstrap and jQuery 3 incompatibility which lead me to the solution of using npm shrinkwrap.

I also read this: https://guide.meteor.com/using-npm-packages.html#npm-shrinkwrap which told me how to use shrinkwrap.

Well, now when I run ‘meteor npm shrinkwrap’ it gives me the following:

npm ERR! Darwin 15.2.0
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "shrinkwrap"
npm ERR! node v4.4.7
npm ERR! npm  v2.15.8

npm ERR! Problems were encountered
npm ERR! Please correct and try again.
npm ERR! missing: meteor-node-stubs@~0.2.0, required by app@
npm ERR! 
npm ERR! If you need help, you may report this error at:
npm ERR!     <https://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request:
npm ERR!     ...$ meteor npm shrinkwrap
npm ERR! Darwin 15.2.0
npm ERR! argv "/Users/Jeremiah/.meteor/packages/meteor-tool/.1.4.0-1.l0olq8++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/node" "/Users/Jeremiah/.meteor/packages/meteor-tool/.1.4.0-1.l0olq8++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/npm" "shrinkwrap"
npm ERR! node v4.4.7
npm ERR! npm  v3.10.5

I tried looking up the ‘missing meteor-node-stubs’ but can’t seem to find exactly what that means or how to correct it.

Any help is appreciated


#2
meteor npm i

will install any dependencies referenced in package.json which are missing (including meteor-node-stubs).


#3

Thank you! That worked.