Help with SSL on galaxy


#1

I am using galaxy. I have a valid cert via letsencrypt.
I installed force-ssl.
Am I missing a step?

-----------------ERROR---------------------------------
------------------------------------------------------------
This site can’t provide a secure connection

[domain name] sent an invalid response.
ERR_SSL_PROTOCOL_ERROR
------------------------------------------------------------


#2

It looks like you’re supplying your own custom Let’s Encrypt certificate. Have you tried removing this cert and instead using the Let’s Encrypt option that comes with Galaxy out of the box? I’ve used their Let’s Encrypt support with multiple apps now, and it has worked perfectly every time.


#3

I read about that option in the docs, but it isn’t present on my screen.

My Screen:

This is the screen alluded to in the docs:


#4

Are there any other steps you had to take to enable the “SSL screen” that I am missing?


#5

That’s strange - you’re seeing the older Galaxy interface. I’m not sure why that is - maybe something is cached on your side? You should see the “Generate Certificate” button, so if it doesn’t come up open a new support ticket with Galaxy.


#6

I tried using a different browser and a different computer, but no change. I will open a support ticket.
Thank you for your help


#7

No problem - just so you know what it should look like, here’s a screenshot:


#8

They will help you update to a newer version of galaxy. I was also confused that all users wasn’t updated automatically.