Heroku, Meteor, and Let's Encrypt [Solved]

Has anyone deployed to Heroku and set up SSL using Let’s Encrypt?

I followed Heroku’s guide for their new SSL beta and this blog post. (Yeah, the blog post say it’s with Rails but that’s only to render the verifying key so it should be the same)

I’ve gotten the certificates generated and added them to the app. I also updated the DNS targets.

When I do _certs:info, I get the expected output.

But when I do curl -vI, I get subject: C=US; ST=California; L=San Francisco; O=Heroku, Inc.; CN=*.herokuapp.com. *.herokuapp.com should be replaced with my domain, correct?

What am I missing? Do I need the force-ssl package?

In case anyone else has this question, I wrote up a StackOverflow answer here

As it turns out, the issue had to do with caching when I ran the curl command. By passing the argument -H "Cache-Control: no-cache", I was able to verify that it was indeed working.

1 Like

Does it work for free Heroku apps? Not hobby and up.

From their SSL page

Heroku SSL is included for free on any app that uses paid dynos: Hobby, Standard-1X, Standard-2X, Performance-M and Performance-L

But you only need to pay for it if you also want a custom domain. Heroku automatically provides SSL if you keep to their herokuapp.com domain