How can I get Atom to create "normal" text for copying-and-pasting?


#1

When I copy and paste code from the Atom Editor to somewhere else, such as Notepad, it goes from looking “normal” in the Atom editor to all “minified” in Notepad. For example, this code:

    'change .payments' : function(event){
      var paymentTot = $('#paymenttotal').val();
      paymentTot = parseInt(paymentTot) || 0;
      var targetVal = $(event.target).val();
      targetVal = parseInt(targetVal);
      paymentTot = paymentTot + targetVal;
      $('#paymenttotal').val(paymentTot);
    },

…looks like this:

Line breaks seem to be converted to tabs, or some such.

If I paste the snippet into StackOverflow, it looks more or less “normal,” though. However, it still doesn’t quite align as it should without some tweaking/fiddling.

In File > Settings, Atom has a “File Encoding” option, which is set to utf8 by default; is this the culprit? Should I set it to something else? Or am I barking up the wrong tree?