How to connect domain DNS records to Galaxy?

Setting up app to Galaxy, which is currently hosted by Digital Ocean.

So I setup an account with Galaxy and mlab. Now I am very confused where the new app is? My comandline says the deployment was successful.

Deploying to myappcom.
Now serving at

But the domain records from the company is purchased the domain from is not set to Galaxy. Is it set to Digital Ocean. so when I go to it goes to the old app on Digital Ocean. How do I set the DNS records so it goes to Galaxy?

this link doesnt explain it clearly.

the A record is pointing towards Digital Ocean IP adress. Do I delete this?

In GoDaddy, I have sometHing called CNAME.
Do I change host to “” with this last full stop?
what about where it says points to?

Getting Galaxy wired up with your DNS provider is easiest if you aren’t using a naked domain (see yes-www). So if you’re open to using something like or then you can use the easier CNAME option. Let’s assume you want Via GoDaddy add a CNAME record that points www to (if you want your app to be reachable at Then just make sure that when you deploy to Galaxy the domain name you specify via the deploy command line matches your CNAME setup, so: meteor deploy --settings settings.json

With this approach, any existing A records you have in place don’t need to change. As an optional step you could then also add a domain forwarding rule via GoDaddy so that when people access your naked domain,, they are forwarded to http[s]://

1 Like

i changed it to where it says “points to” to “” hosting is left at “www”

give this an hour to smooth out.

so far an error.

404 Not Found: No applications registered for host ‘’.

Just to confirm - when you deploy your app, are you specifying on the common line via meteor deploy? meteor deploy --settings settings.json

changed it from to

Thanks alot! works now. next step is to get the old database up.

in my culture this means we’re married.


Congrats on your marriage.

What’s good with the domain forwarding rule?

domain forwarding working.

Curious how you entered the domains in the “Domains & Encryption” section of galaxy settings.

I’m pretty sure I have a similar setup as yours, with my GoDaddy www CNAME set to “” and domain forwarding set to ‘’. Waiting to see if DNS changes will properly propagate, but seems like it should have resolved by now. I set my TTL to the minimum of 600 seconds. My Galaxy deployment script uses ‘’. ROOT_URL is ‘’ (if it matters).

When I visit in chrome I get “server DNS address could not be found” and when I visit ‘’ I get redirected to an older path I had setup, and the error “This site can’t provide a secure connection - sent an invalid response”. Not having luck clearing my DNS cache in chrome.

My galaxy settings:
Domain - - - - - - - - - - - - Encryption’ - - - - - - Enabled • Force HTTPS

** UPDATE **
If I use incognito, works, but goes to “server DNS address could not be found”