How to force meteor to a previous version


#1

One of my projects is currently running 1.2-rc.2, and I’d like to revert it to the current version 1.1.0.3 AND it’s required packages. Using meteor update --version 1.1.0.3 I get, “***This project is at the latest release which is compatible with your current package constraints.***” But I don’t want it at the version it’s at, I need to get it back to 1.1.0.3 and remove packages I don’t need from 1.2-rc.2!

Please any help would be greatly appreciated!


#2

You can run any back level version of Meteor with the --release switch, so:

meteor --release 1.1.0.3

Downgrade from 1.2 to 1.1
#3

Tried it and got these error messages which prevent me from starting it in version 1.1.0.3:

meteor --release 1.1.0.3 -p4000
=> Using Meteor 1.1.0.3 as requested (overriding Meteor 1.2.1)

[[[[[ ~/Documents/workspace/worker ]]]]]      

=> Started proxy.                             
=> Started MongoDB.                           
=> Errors prevented startup:                  

While selecting package versions:
error: unknown package: isobuild:compiler-plugin
Required by: ecmascript 0.1.3-plugins.1
Required by: ecmascript 0.1.3-plugins.1

unknown package: isobuild:minifier-plugin
Required by: standard-minifiers 1.0.2

=> Your application has errors. Waiting for file change.

Any suggestions for these errors?


#4

Check that none of the packages your app relies on is using api.fromVersion('1.2-rc2') or api.fromVersion('METEOR@1.2')