How to npm install specific fork of a package?


#1

there are more than one package named react-bootstrap-datetimepicker

so how can i install the forked version of the repo?

Something like?

npm install react-bootstrap-datetimepicker : "git://github.com/LKay/react-bootstrap-datetimepicker"

#2

Try:

npm install git+https://git@github.com/LKay/react-bootstrap-datetimepicker

or

npm install LKay/react-bootstrap-datetimepicker

Relevant SO page /w more options: http://stackoverflow.com/questions/17509669/how-to-install-nodejs-package-from-github-directly


#3

When using NPM with meteor, please make sure to use meteor npm instead of just npm. This is to ensure modules that have binary dependencies will built with the correct libraries.

Also, here’s the full official instructions of what npm commands and styles are supported (you can also do tarballs, etc.):

https://docs.npmjs.com/cli/install

:slight_smile:


#4

so will the latest meteor npm install overwrite the previous install I assume? Or must I first remove before install ?

> meteor npm install LKay/react-bootstrap-datetimepicker
npm ERR! Windows_NT 6.1.7601
npm ERR! argv "C:\\Users\\SEC11\\AppData\\Local\\.meteor\\packages\\meteor-  tool\\1.3.2_4\\mt-os.windows.x86_32\\dev_bundle\\bin\\\\node.exe" "C:\\User
s\\SEC11\\AppData\\Local\\.meteor\\packages\\meteor-tool\\1.3.2_4\\mt-     os.windows.x86_32\\dev_bundle\\lib\\node_modules\\npm\\bin\\npm-cli.js" "install
" "LKay/react-bootstrap-datetimepicker"
npm ERR! node v0.10.43
npm ERR! npm  v2.14.22
npm ERR! code EPEERINVALID

npm ERR! peerinvalid The package react@15.1.0 does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer formsy-react@0.17.0 wants react@^0.14.0
npm ERR! peerinvalid Peer griddle-react@0.5.1 wants react@^0.14.3 || ^15.0.1
npm ERR! peerinvalid Peer react-bootstrap@0.29.4 wants react@>=0.14.0
npm ERR! peerinvalid Peer react-bootstrap-datetimepicker@1.0.0 wants     react@>=0.14.0
npm ERR! peerinvalid Peer react-dom@15.1.0 wants react@^15.1.0
npm ERR! peerinvalid Peer react-mounter@1.2.0 wants react@0.14.x || 15.x.x
npm ERR! peerinvalid Peer react-select@1.0.0-beta13 wants react@^0.14 || ^15.0.0-rc     || ^15.0
npm ERR! peerinvalid Peer react-addons-css-transition-group@15.1.0 wants react@^15.1.0
npm ERR! peerinvalid Peer react-addons-pure-render-mixin@15.1.0 wants react@^15.1.0
npm ERR! peerinvalid Peer react-addons-test-utils@15.1.0 wants react@^15.1.0
npm ERR! peerinvalid Peer react-input-autosize@0.6.13 wants react@^0.14 || ^15.0.0-rc || ^15.0
npm ERR! peerinvalid Peer react-input-slider@1.5.0 wants react@^0.14.0
npm ERR! peerinvalid Peer react-komposer@1.8.0 wants react@^0.14.3 || ^15.0.0
npm ERR! peerinvalid Peer react-simple-di@1.2.0 wants react@^0.14.0 || ^15.0.0
npm ERR! peerinvalid Peer react-toolbox@0.16.2 wants react@^0.14 || ^15.0.1
npm ERR! peerinvalid Peer react-favicon@0.0.4 wants react@>=0.12.0 < 15.0.x
npm ERR! peerinvalid Peer redbox-react@1.2.6 wants react@^0.14.0 || ^15.0.0
npm ERR! peerinvalid Peer uncontrollable@3.2.4 wants react@>=0.11.0
npm ERR! peerinvalid Peer @kadira/react-split-pane@1.4.2 wants react@^0.14.8 || ^15.0.0
npm ERR! peerinvalid Peer @kadira/storybook@1.28.1 wants react@^0.14.7 || ^15.0.0
npm ERR! peerinvalid Peer enzyme@2.3.0 wants react@0.13.x || 0.14.x || ^15.0.0-0
npm ERR! peerinvalid Peer input-moment@0.1.0 wants react@^0.14.0
npm ERR! peerinvalid Peer react-overlays@0.6.3 wants react@>=0.14.0
npm ERR! peerinvalid Peer react-modal@1.3.0 wants react@^0.14.0 || ^15.0.0-0
npm ERR! peerinvalid Peer @kadira/storybook-core@1.26.2 wants react@^0.14.7 ||  ^15.0.0
npm ERR! Please include the following file with any support request:
npm ERR!     C:\Users\SEC11\PycharmProjects\spark2acs\npm-debug.log

or

> meteor npm install git+https://git@github.com/LKay/react-bootstrap-datetimepicker
npm ERR! Windows_NT 6.1.7601
npm ERR! argv "C:\\Users\\SEC11\\AppData\\Local\\.meteor\\packages\\meteor-    tool\\1.3.2_4\\mt-os.windows.x86_32\\dev_bundle\\bin\\\\node.exe" "C:\\User
s\\SEC11\\AppData\\Local\\.meteor\\packages\\meteor-tool\\1.3.2_4\\mt-    os.windows.x86_32\\dev_bundle\\lib\\node_modules\\npm\\bin\\npm-cli.js" "install
" "git+https://git@github.com/LKay/react-bootstrap-datetimepicker"
npm ERR! node v0.10.43
npm ERR! npm  v2.14.22
npm ERR! code EPEERINVALID

npm ERR! peerinvalid The package react@15.1.0 does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer formsy-react@0.17.0 wants react@^0.14.0
npm ERR! peerinvalid Peer griddle-react@0.5.1 wants react@^0.14.3 || ^15.0.1
npm ERR! peerinvalid Peer react-bootstrap@0.29.4 wants react@>=0.14.0
npm ERR! peerinvalid Peer react-bootstrap-datetimepicker@1.0.0 wants react@>=0.14.0
npm ERR! peerinvalid Peer react-dom@15.1.0 wants react@^15.1.0
npm ERR! peerinvalid Peer react-mounter@1.2.0 wants react@0.14.x || 15.x.x
npm ERR! peerinvalid Peer react-select@1.0.0-beta13 wants react@^0.14 || ^15.0.0-rc || ^15.0
npm ERR! peerinvalid Peer react-addons-pure-render-mixin@15.1.0 wants react@^15.1.0
npm ERR! peerinvalid Peer react-addons-css-transition-group@15.1.0 wants react@^15.1.0
npm ERR! peerinvalid Peer react-addons-test-utils@15.1.0 wants react@^15.1.0
npm ERR! peerinvalid Peer react-input-autosize@0.6.13 wants react@^0.14 || ^15.0.0-rc || ^15.0
npm ERR! peerinvalid Peer react-favicon@0.0.4 wants react@>=0.12.0 < 15.0.x
npm ERR! peerinvalid Peer react-input-slider@1.5.0 wants react@^0.14.0
npm ERR! peerinvalid Peer react-komposer@1.8.0 wants react@^0.14.3 || ^15.0.0
npm ERR! peerinvalid Peer react-simple-di@1.2.0 wants react@^0.14.0 || ^15.0.0
npm ERR! peerinvalid Peer react-toolbox@0.16.2 wants react@^0.14 || ^15.0.1
npm ERR! peerinvalid Peer redbox-react@1.2.6 wants react@^0.14.0 || ^15.0.0
npm ERR! peerinvalid Peer uncontrollable@3.2.4 wants react@>=0.11.0
npm ERR! peerinvalid Peer @kadira/storybook@1.28.1 wants react@^0.14.7 || ^15.0.0
npm ERR! peerinvalid Peer @kadira/react-split-pane@1.4.2 wants react@^0.14.8 || ^15.0.0
npm ERR! peerinvalid Peer enzyme@2.3.0 wants react@0.13.x || 0.14.x || ^15.0.0-0
npm ERR! peerinvalid Peer input-moment@0.1.0 wants react@^0.14.0
npm ERR! peerinvalid Peer react-modal@1.3.0 wants react@^0.14.0 || ^15.0.0-0
npm ERR! peerinvalid Peer react-overlays@0.6.3 wants react@>=0.14.0
npm ERR! peerinvalid Peer @kadira/storybook-core@1.26.2 wants react@^0.14.7 || ^15.0.0

npm ERR! Please include the following file with any support request:
npm ERR!     C:\Users\SEC11\PycharmProjects\spark2acs\npm-debug.log

Here is my package.json:

{
  "name": "spark2acs",
  "private": true,
  "version": "1.0.0",
  "scripts": {
    "lint": "eslint ./lib ./client ./server --ext .js .jsx",
    "lintfix": "npm run lint -- --fix",
    "testonly": "mocha .scripts/mocha_boot.js client/**/tests/**/*.js --compilers js:babel-core/register",
    "test": "npm run lint && npm run testonly",
    "test-watch": "npm run testonly -- --watch --watch-extensions js",
    "storybook": "start-storybook -p 9001 -s ./public"
  },
  "dependencies": {
    "babel-plugin-transform-class-properties": "^6.9.1",
    "bluebird": "^3.4.0",
    "domready": "^1.0.8",
    "formsy-react": "^0.17.0",
    "formsy-react-components": "^0.6.6",
    "griddle-react": "^0.5.1",
    "lodash": "4.6.1",
    "mantra-core": "^1.5.0",
    "meteor-node-stubs": "~0.2.0",
    "moment": "^2.13.0",
    "react": "^15.1.0",
    "react-bootstrap": "^0.29.4",
    "react-bootstrap-datetimepicker": "0.0.22",
    "react-dom": "^15.1.0",
    "react-mounter": "^1.2.0",
    "react-select": "^1.0.0-beta13",
    "rsvp": "^3.2.1",
    "unirest": "^0.4.2"
  },
  "devDependencies": {
    "@kadira/storybook": "^1.7.0",
    "babel": "^6.3.26",
    "babel-core": "^6.9.1",
    "babel-loader": "^6.2.4",
    "babel-plugin-add-module-exports": "^0.1.2",
    "babel-plugin-react-require": "2.x.x",
    "babel-plugin-react-transform": "^2.0.2",
    "babel-plugin-transform-decorators-legacy": "^1.3.2",
    "babel-polyfill": "6.x.x",
    "babel-preset-es2015": "^6.9.0",
    "babel-preset-react": "^6.5.0",
    "babel-preset-stage-0": "^6.3.13",
    "babel-preset-stage-2": "6.x.x",
    "babel-root-slash-import": "1.x.x",
    "chai": "3.x.x",
    "css-loader": "^0.23.1",
    "enzyme": "^2.2.0",
    "eslint": "1.10.x",
    "eslint-plugin-react": "3.15.x",
    "expose-loader": "^0.7.1",
    "extract-text-webpack-plugin": "^1.0.1",
    "file-loader": "^0.8.5",
    "html-webpack-plugin": "^2.19.0",
    "jsdom": "^8.0.4",
    "json-loader": "^0.5.4",
    "less": "^2.3.1",
    "less-loader": "^2.2.2",
    "mocha": "2.x.x",
    "raw-loader": "^0.5.1",
    "react-addons-test-utils": "^15.1.0",
    "sinon": "1.17.x",
    "style-loader": "^0.13.1",
    "url-loader": "^0.5.7"
  }
}

Can I ignore them since react-bootstrap-datetimepicker is now updated within the dependencies:

"dependencies": {

 "react-bootstrap-datetimepicker": "0.0.22",

}