How to run 1.4 on Compose MongoDB Classic?

We’re running an app on Compose’s MongoDB Classic but we’re getting this error:

MongoError: seed list contains no mongos proxies, replicaset connections requires the parameter replicaSet to be supplied in the URI or options object, mongodb://server:port/db?replicaSet=name

According to this article, adding a replicaSet to the OPLOG url should fix the issue but it doesn’t fix it for me. Did anyone else run into this problem?

For reference, this is how we’re setting our env variables for mongo url and mongo oplog url:

SET MONGO_URL=mongodb://,mongolayerurl:port/dbname?replicaSet=set-string
SET MONGO_OPLOG_URL=mongodb://,mongolayerurl:port/local?replicaSet=set-string


One of my apps is running on Compose’s MongoDB Classic.

You need to make sure the urls are 100% correct.

You also need authSource in your MONGO_OPLOG_URL

Worst case removing the MONGO_OPLOG_URL should also work you lose oplog but your app will start again.