How to stay at 1.2.1?


#1

How can I force my app to stay at 1.2.1? After doing “meteor update”, everything was upgraded to 1.3 - atm I don’t have the time to check if everything there works fine. Is there any config setting for it?

Running meteor --release 1.2.1 ends with “Downloading 63 packages” and finishes with “You have errors in your application”


#2

Other than the obvious revert your source control, which I’m now going to assume you don’t have:

meteor update --release 1.2.1 will convert the project back to 1.2.1


#3

I’m using git and it only works with a revert. Going from 1.2 to 1.3 and back to 1.2 ended up in a broken application and dependency problems, if I do it via --release parameter.

I’m looking for an option where I can force the version without adding --release on every meteor update command.


#4

If there is such an option, I’m not aware of it. I always make sure my updates are a fresh commit so that I can revert any changes if I don’t like the results, so I have never had need of such a thing. I also only update package versions when I’m working on a new feature and as such generally move to the new version of meteor at the same time. Sorry I couldn’t be more help.


#5

Having the same problem, tried to upgrade to 1.3, found out it doesn’t work on windows, and when forcing to go back to 1.2.1 it ends on a infinite downloading meteor-tools 1.1.0

P.S. It’s a trap! :frowning: :frowning:

Update: Found out that actually creating a new meteor app with --release 1.2.1 took extremely long but it worked, so used that to fetch back 1.2.1 packages and then could update my failed 1.3 update attempt
to 1.2.1 again (I had deleted 1.2.1 for a clean 1.3 install)… phew not everything was lost :sweat_smile:


#6

I didn’t do anything and had a 1.2.1 app that has been working for months… all of a sudden once 1.3 released - then just running meteor (not meteor --update) sent things into a frenzy. Now I cannot even run the 1.2 app. So I tried making a new 1.3 app with the plan to copy the source over, but that hangs too. Think someone pulled the trigger way too early and hosed even those of us that did not plan to move to 1.3 just yet in the process… Not sure what to try from here and I have to figure out something to tell the boss soon…


#7

If you are using git, revert to the last commit before you did the update. Then run meteor --release 1.2.1 and then…never forget to call it on every update command.


#8

balls i hope we dont all get this problem.


#9

I’m having this problem too. Doesn’t matter which command i use… run, list, update, reset, create… it always says "Downloading meteor-tool@1.3.0_3… " and get’s stuck. I really hope this can be fixed fast :confused:


#10

It’s not stuck. It just takes foreeeeveeeer.


#11

how long did it take for you? over here it’s running for over an hour now


#12

Not that long!
I think it was like 10-20 min


#13

You were right greblak, it just took an eternity :astonished: 2.5 hours later it finished and everything executes very quickly.


#14

You can also do meteor update --packages-only but I guess that’s still a moot point since it’s the same problem. :slight_smile:

In Windows-land you can modify the meteor.bat so that if it see update as the first parameter it will automatically add the necessary parameter. I think you can do something similar on Unix.


#15

How can we deploy a Meteor 1.2.1 app, now that RELEASE="1.3" is hardcoded in the install script at https://install.meteor.com?

Most buildpack scripts download and execute the script to install meteor onto cloud hosting.

Would it be better and possible to detect the version of Meteor an app being deployed uses and then install the appropriate version of Meteor, instead of only installing the version that is dictated by the install script?

I wold love to deploy the new version but it doesn’t work (“Error: ENOSPC” when attempting to deploy Meteor 1.3 app), so would like to revert to the previous version until the problem is fixed. Now my web app is completely down.


#16

meteor create --release 1.2.1 still works


#17

Im on a windows box, upgrading to 1.3 has been a nightmare, my app is broken. Im fairly new to Meteor and feel stuck about where to start.Im having a lot of trouble reverting to realease 1.2.1. After I reverted and started my app, a message indicated that v1.3 was being downloaded in the background. I have not experienced this issue with another app on my linux box, hope the issue gets sorted asap.


#18

To answer my own question, I simply tried adding a query string to the install script URL and it worked: https://install.meteor.com/?release=1.2.1

So I am now able to redeploy my Meteor 1.2.1 app.

Though it would still be better if the version of Meteor used by the app was automatically detected so that we wouldn’t have to manually add the query string to the URL.


#19

Nobody is doing any updates! Restarting one’s app is all that it takes. You’ve hosed, what, hundreds if not thousands of users?


#20

What’s your problem? Meteor automatically upgrades to the newst version if you run meteor update.