"HTML template does not exists!" errors after meteor update


#1

On an angular-meteor project, after

$ meteor update (which bumped up the version from 1.3.4.1 to 1.3.4.4)

All templates stopped loading and multiple errors (one per template) appear on the console. All errors are of the form:
HTML template does not exists! You can disable this error by following this guide

For the fun of it, here’s a screenshot:

More details on stackoverflow

Ideas?


Problem with angular-templates
#2

I have tried it out with my boilerplate no issues so far.


#3

I am seeing the exact same issue, unfortunately.


#4

Same issue here. Important to note I’m using angular1 and not angular2. Any new on this?


#5

Not yet on my end. I plan to look into it next week. Hopefully by then the updates would have solved it


#6

Workaround for me (angular 1) is to import every single html template.

   import templateTabs from '/client/templates/tabs.html'

   this.$stateProvider
        .state('tab', {
            url: '/tab',
            abstract: true,
            templateUrl: templateTabs
        })

#7

@milanperovic has right. Every single html must be import. But in my app work:
import templateTabs from ‘client/templates/tabs.html’ without a first slash.

Maybe this is something that should be fix in core of meteor.


#8

Works for me.
I use coffee and rewrote the tutorial code in coffee. Fixed this problem by add this line in my code.