I can not link my mlab database address in meteor up


#1

I am trying to deploy my meteor application to digitalocean. I have set my mlab database address in the mup.js in the environment variables, but when I log into my mlab profile to manage my database. My application does not register the data in the mlab address but in another part that I do not know where. When I set my address in mup.js in the environment variables.

Where is this application inserting data? Because it is not doing it in my mlab address as I defined it before.

module.exports = {
  servers: {
    one: {
      // TODO: set host address, username, and authentication method
      host: '1.2.3.4',
      username: 'root',
      pem: '~/.ssh/id_carlo_digital'
      // password: 'server-password'
      // or neither for authenticate from ssh-agent
    }
  },

  app: {
    // TODO: change app name and path
    name: 'perfilesgs',
    path: '.',

    servers: {
      one: {},
    },

    buildOptions: {
      serverOnly: true,
    },

    env: {
      // TODO: Change to your app's url
      // If you are using ssl, it needs to start with https://
      ROOT_URL: 'http://1.2.3.4',
      MONGO_URL: 'mongodb://user:pass@mlab_server:port/perfilesgs',
    },

    // ssl: { // (optional)
    //   // Enables let's encrypt (optional)
    //   autogenerate: {
    //     email: 'email.address@domain.com',
    //     // comma separated list of domains
    //     domains: 'website.com,www.website.com'
    //   }
    // },

    docker: {
      // change to 'kadirahq/meteord' if your app is using Meteor 1.3 or older
      image: 'abernix/meteord:base',
      prepareBundle: false
    },

    // Show progress bar while uploading bundle to server
    // You might need to disable it on CI servers
    enableUploadProgressBar: true
  },

  mongo: {
    version: '3.4.1',
    servers: {
      one: {}
    }
  }
};

#2

Remove that part and deploy again and the try. I had the same issue yesterday.


#3

Thanks so much. Now it works