I get errors when in command line: meteor add accounts-password


#1

Microsoft Windows [Version 10.0.10586]
© 2015 Microsoft Corporation. All rights reserved.

C:\Windows\System32>cd …/…/

C:>cd meteor/leaderboard

C:\meteor\leaderboard>meteor add accounts-password
=> Errors while adding packages:

While loading package npm-bcrypt@0.8.7:
error: Command failed:
C:\Users\my\AppData\Local.meteor\packages\meteor-tool\1.4.0\mt-os.windows.x86_32\dev_bundle\bin\npm.cmd
rebuild --no-bin-links --update-binary
gyp ERR! build error
gyp ERR! stack Error:
C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe failed with
exit code: 1
gyp ERR! stack at ChildProcess.onExit
(C:\Users\my\AppData\Local.meteor\packages\meteor-tool\1.4.0\mt-os.windows.x86_32\dev_bundle\lib\node_modules\node-gyp\lib\build.js:276:23)
gyp ERR! stack at emitTwo (events.js:87:13)
gyp ERR! stack at ChildProcess.emit (events.js:172:7)
gyp ERR! stack at Process.ChildProcess._handle.onexit
(internal/child_process.js:200:12)
gyp ERR! System Windows_NT 10.0.10586
gyp ERR! command
"C:\Users\my\AppData\Local\.meteor\packages\meteor-tool\1.4.0\mt-os.windows.x86_32\dev_bundle\bin\node.exe"
“C:\Users\my\AppData\Local\.meteor\packages\meteor-tool\1.4.0\mt-os.windows.x86_32\dev_bundle\lib\node_modules\node-gyp\bin\node-gyp.js”
"rebuild"
gyp ERR! cwd
C:\Users\my\AppData\Local.meteor\packages\npm-bcrypt\0.8.7\npm\node_modules.temp-bqnrea\node_modules\bcrypt
gyp ERR! node -v v4.4.7
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

npm ERR! Windows_NT 10.0.10586
npm ERR! argv
"C:\Users\my\AppData\Local\.meteor\packages\meteor-tool\1.4.0\mt-os.windows.x86_32\dev_bundle\bin\node.exe"
“C:\Users\my\AppData\Local\.meteor\packages\meteor-tool\1.4.0\mt-os.windows.x86_32\dev_bundle\lib\node_modules\npm\bin\npm-cli.js”
“rebuild” “–no-bin-links” "–update-binary"
npm ERR! node v4.4.7
npm ERR! npm v3.10.5
npm ERR! code ELIFECYCLE
npm ERR! bcrypt@0.8.7 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the bcrypt@0.8.7 install script ‘node-gyp rebuild’.
npm ERR! Make sure you have the latest version of node.js and npm
installed.
npm ERR! If you do, this is most likely a problem with the bcrypt package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project
with:
npm ERR! npm bugs bcrypt
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls bcrypt
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!
C:\Users\my\AppData\Local.meteor\packages\npm-bcrypt\0.8.7\npm\node_modules.temp-bqnrea\npm-debug.log
gyp ERR! build error
gyp ERR! stack Error:
C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe failed with
exit code: 1
gyp ERR! stack at ChildProcess.onExit
(C:\Users\my\AppData\Local.meteor\packages\meteor-tool\1.4.0\mt-os.windows.x86_32\dev_bundle\lib\node_modules\node-gyp\lib\build.js:276:23)
gyp ERR! stack at emitTwo (events.js:87:13)
gyp ERR! stack at ChildProcess.emit (events.js:172:7)
gyp ERR! stack at Process.ChildProcess._handle.onexit
(internal/child_process.js:200:12)
gyp ERR! System Windows_NT 10.0.10586
gyp ERR! command
"C:\Users\my\AppData\Local\.meteor\packages\meteor-tool\1.4.0\mt-os.windows.x86_32\dev_bundle\bin\node.exe"
“C:\Users\my\AppData\Local\.meteor\packages\meteor-tool\1.4.0\mt-os.windows.x86_32\dev_bundle\lib\node_modules\node-gyp\bin\node-gyp.js”
"rebuild"
gyp ERR! cwd
C:\Users\my\AppData\Local.meteor\packages\npm-bcrypt\0.8.7\npm\node_modules.temp-bqnrea\node_modules\bcrypt
gyp ERR! node -v v4.4.7
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

npm ERR! Windows_NT 10.0.10586
npm ERR! argv
"C:\Users\my\AppData\Local\.meteor\packages\meteor-tool\1.4.0\mt-os.windows.x86_32\dev_bundle\bin\node.exe"
“C:\Users\my\AppData\Local\.meteor\packages\meteor-tool\1.4.0\mt-os.windows.x86_32\dev_bundle\lib\node_modules\npm\bin\npm-cli.js”
“rebuild” “–no-bin-links” "–update-binary"
npm ERR! node v4.4.7
npm ERR! npm v3.10.5
npm ERR! code ELIFECYCLE
npm ERR! bcrypt@0.8.7 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the bcrypt@0.8.7 install script ‘node-gyp rebuild’.
npm ERR! Make sure you have the latest version of node.js and npm
installed.
npm ERR! If you do, this is most likely a problem with the bcrypt package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project
with:
npm ERR! npm bugs bcrypt
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls bcrypt
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!
C:\Users\my\AppData\Local.meteor\packages\npm-bcrypt\0.8.7\npm\node_modules.temp-bqnrea\npm-debug.log

C:\meteor\leaderboard>


Cannot add accounts-password
#2

same error for me … :frowning:


#3

Both my meteor and native npm versions are the same at 3.10.5, Meteor at 1.4.0.1
.


#4

Yes, I have the same issue. I already ran into some problems updating 1.4 to 1.4.0.1 and now this. Anybody has a solution so we can go forward? Thanks.


#5

c++ build tools 2015 …
give it a try !


Error after 'meteor add accounts-password'
#6

I received a similar error with an application that’s been in use for almost a year. I’m running under Linux. After many hours of trying this and that I’m back up and running. This will sound like voodoo but the procedure has worked for me under my development setup c9.io and my production server digitalocean.com

I hope you have a current copy of your source.
My application is ONLY using atmospherejs packages.

  1. Do a fresh install of Meteor 1.4.0.1
  2. meteor create yourapplication
  3. cd yourapplication
  4. delete all directories and files that were created by default
  5. copy the source for all directory and files you need from your source
  6. meteor add accounts-password
  7. remove/add the rest of the packages as needed

I found that if I did not add accounts-password first it messed things up.

Here’s the normal sequence I used that caused problems.

meteor remove insecure
meteor remove autopublish
meteor add iron:router
meteor add accounts-ui
meteor add accounts-password
meteor add sacha:spin
meteor add email
meteor add twbs:bootstrap
meteor add http

I was trying to create a repeatable error by just creating a default application and only adding accounts-password… and it just worked. No errors.

Good luck


#7

This worked for me, thanks!

I had created a new project to test on Mac/Linux and had only installed ian:accounts-ui-bootstrap-3 before accounts-password.

I used meteor remove ian:accounts-ui-bootstrap-3

and then installed accounts-password with:

meteor add accounts-password

followed by

meteor add ian:accounts-ui-bootstrap-3


#8

Thanks for your help. I am new at this and wasn’t able to implement your solutions, but I found this here:

I think I can also use cmd.exe with administrator rights. I don’t think I have to first navigate to any particular folder; I just type ‘meteor npm install --global --production windows-build-tools’ and press enter and wait maybe an hour or more. Like you say: there is no confirmation.


#9

You’re welcome.

Well as they say once is chance that’s me and twice is coincidence that’s
you I guess we need a third time to really confirm the issue


#10

Is there no resolution yet?


#11

Same issue on win7 and win 10

Even though I am able to do this as stated in the guide.

To test that your compiler toolchain is installed and working properly, try installing any binary npm package in your application using meteor npm. For example, run meteor npm install bcrypt then meteor node, then try calling require(“bcrypt”) from the Node shell.

And I am not able to install accounts-password in a new, clean App either


#12

Your solution worked for me. Much appreciated! By the way, for those interested, I’m using Linux not Windows because I kept running into similar errors while trying this on Windows 7.


#13

I had this problem earlier this week and I created a new project from 1.3.5.1( “meteor create project --release 1.3.5.1” )

Then added accounts-password

Then upgraded to 1.4

No more errors


#14

I just tested this on windows,

accounts-password worked fine in 1.3.5.1 but once you update it will throw errors due to bcrypt.

Were u using windows?


#15

Yes

You still need to follow the migration steps and be sure to have visual studio installed

I’m on windows 8 64bit


#16

Very good!
Now it works on windows 10.
Thank you very much!