I need to be able to run Meteor dev server offline


#1

I have no WiFi at home, and sometimes the internet I get at the library and other people’s places is not too reliable

I have noticed that upon running the meteor command from the project’s directory it will boot up ONLY when I’m connected to the internet, not when I’m offline.

I’m really new to this, I’m halfway through the tutorial and I want to at least be able to finish it.

is there a way around this? or at least an explanation?


[Meteor 1.3] I cannot run my new project :(
#2

Meteor normally runs just fine offline.
Please be more specific, in what way does “project directory not boot up” ?
What OS are you running under?


#3

@jesperwe
I was having exactly this assertion issue, which seems to be gone now. maybe because I had the chance to get my updates? [Meteor 1.3] I cannot run my new project :(


#4

I keep having this issue!
yesterday it gave me the same error again, I have saved the traceback, it goes like this:

Assertion `s == buf’ failed at …/src/platform-linux.cc:59
Aborted

This error Still ONLY happens when I’m offline at home.
yesterday I double checked for updates, yet at night I went home and the same error happened again.
I am even considering the possibility that its the fact that the system booted up disconnected from the internet? i dont know I’m just making guesses, I’d appreciate the help I really need to be able to work offline.


#5

Hi,

doing sudo apt-get update worked for me. I didn’t have the issue since then so didn’t take time to look for the root cause sorry :frowning:


#6

@ibox
yes, indeed, however, the other day I checked for updates many many many times, then turned off the computer and went home, I booted up my laptop there, and the problem just happened Again!

I’ll tell you if I find out what’s going on exactly, if anyone knows anything else, please tell me, my first step right now is to just find where platform-linux.cc is.
I’ll keep updating this thread.


#7

I have a new test I want to do, which shall put things into perspective,
I’m going to run meteor after booting up Windows while offline
let’s see if that changes something,
I’ll also update tomorrow to just see if this problem still persists and see if I can find the damn file and find out the underlying cause of this issue or at least some clues


#8

After some research I’ve found out what’s up
the error is produced by an npm package called NetRoute
it’s used to obtain data about your connection using /proc/net/route

this file is only Ever generated when you establish an internet connection, so the assertion to check if you can succesfully read the file fails when you boot up with no internet, however it will not fail if you just disconnect from your WiFi network afterwards

I fixed my local copy by commenting the Assertion which is in line 59 of the file ~/.meteor/packages/meteor-tool/.1.3.2_4.10vjklo++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/lib/node_modules/netroute/src

I became a contributor to the project, however I’m not sure how to contribute this fix to MeteorJS since its not technically a meteor issue, but a NetRoute issue.

Hope it helps someone, because I could’ve certainly used this information

@ibox there’s your explanation, my friend


#9

Awesome! Great anlysis, thanks :slight_smile:


#10

still an issue with meteor 1.4.1 on debian/linux.

are there any workarounds?


#11

There’s also an issue with running Cordova offline…