I screwed up my project - phone doesn't connect anymore

I have a one-year old project running with ionic+meteor. Everything worked fine until I did a ‘npm update’. After that it wasn’t working anymore and I didn’t know the specific versions of all packages, because they were marked with for example “^” in the package.json.
Luckily I found an old back-up of my ‘node_moduls’ folder. After replacing the folders the project was running again.
But on the phone it seams it’s not connecting to the server.
This can be a bigger problem or maybe a wrong configuration.

So I wanted to start to check if it tries to connect to the correct IP. But I didn’t find a way how I could log the set IP to the console for example.

Can someone tell me, where I have to set the server-IP or how I can log/debug the used IP to see if it uses the correct one?

At the moment I set the IP config in the index.html-file, but maybe this only works for my laptop, but not on the phone.

    (function() {
      __meteor_runtime_config__ = {
        // Your server's IP address goes here

Thank you very much for helping!

Hey all,
it suddenly worked in the meanwhile but I am back to the same problem again.
When it was working, I was able to change the IP as posted above in the index.html file and it connected to the new IP. But suddenly it is not connecting anywhere again…

I tried to set the DDP_URL at several placed, but it doesn’t change anything.

Do you know any way how I could debug the loginWithPassword-function to see what’s going on and why it doesn’t do anthing on my phone?

Meteor.loginWithPassword({username: username}, password, (e: Error) => {
      if (e) return this.handleError(e);



The callback is not called, don’t know what to do more. Thank you

I just added a debug-button printing Meteor.status() and now I know that my app is not connected and it keeps in the waiting-state:


Any idea why? Any idea, how to figure out where it definitely tries to connect to, to check if it’s correct configured?

Made a clean clone of my repo and it’s working again