[I was wrong] Meteor 1.8-rc-16 server method doesn't reload on modified


#1

On development (my laptop, ubuntu 18.04), I modified the method, which is only available on server, Meteor server restarts (I got this on terminal => Meteor server restarted)
But the method doesn’t get updated. I have to close server and start again.
Maybe I was wrong. Does anyone have this issue?


#2

If you are calling the method from client then yes, because server was updated, but the client still has the old version so you need to manually refresh the client.


#3

@storyteller: that doesn’t sound right :confused:

If the code is only on the server, then only the server needs to restart. The client makes an API call, so does not need to be aware of what’s happened to the server.

If the method code is on the server and the client (simulation), then the client will restart as well.

Perhaps this is a bug in 1.8 (I haven’t tested): @minhna: have you raised a GitHub issue?


#4

I haven’t created issue yet. I want to make sure it’s true before I do.


#5

This is something that I have been experiencing before 1.8. I think it might be related to latency compensation or caching in dev, but honestly I’m only guessing. If I encounter this issue soon I’ll try to get a reproduction of it.


#6

It’s fine on 1.7.0.5. I will create a github repository for this.


#7

Everything is working as expected right now. The issue has gone. I have no idea :slight_smile:


#8

I have actually experienced this in a project where SSR broke client reload. It is very strange that the server some how runs the code from the previous build, but I can confirm this happens.

Unfortunately I didn’t have the time to create a reproduction and so never filed an issue.


#9

I also used to experience this every once in a while (around 1.3 or 1.4?) in development. I recall trying to debug some methods that were cached – adding console logs to the top of a method call and not seeing it – and thinking I was going nuts.

I wasn’t ever able to reproduce it, so never filed an issue. If I recall correctly, terminating the server and restarting usually solved it right away.


#10

Ah, yes! :laughing: That is how I found about it as well. Though the fix for me most of the time was just to refresh the client.


#11

This is still not working on METEOR@1.8.0.1.

The client has to be manually reloaded or it calls the old server method.