IE10 error (const) only after deploying, not during dev


#1

Hi guys!

So here I am again with a stupid IE10/babel error.

When I connect to my localhost during development with an IE10 all is working fine, but after a deployment the whole page is dead on IE10 due to a const declaration which was not “babel’fied” to a var.

I am currently in my master branch still using 1.6.0.1. I tried several versions of my devDependencies- meaning I removed some of them, even completely also removed my .babelrc … it all stays the same - working during dev, dead after deployment.

  "devDependencies": {
    "babel-plugin-import": "^1.6.3",
    "babel-plugin-transform-class-properties": "^6.24.1",
    "babel-preset-meteor": "^6.22.0",
    "babel-preset-stage-2": "^6.22.0",
    "chimp": "^0.41.2"
  }

Can someone help? I just don’t understand why this is working in dev but dead after deployment.

EDIT: I also tried running it with the --production flag (prior I removed the force-ssl package so I can visit the page on localhost without ssl) - all working fine on IE10, no problems. isn’t the --production flag pretty much exactly the same what happens on the server after deployment?


EDIT 2:
It seems like completely deleting the docker container prior to deployment fixes this problem. Does anyone have any idea why? maybe some npm 5 problems with caching newer versions of packages and not re-downloading the old ones or something like that?!

God I hate errors like that … 3 hrs wasted with some BS … :roll_eyes: :expressionless:


#2

I don’t think this will solve your issue, but I strongly recommend against having babel-preset-meteor installed via npm, along with any other babel plugins that Meteor automatically installs and uses via the ecmascript package.
It’s a frequent source of issues because of conflicts with the version that Meteor wants to use