Impossible to start meteor


#1

Hello,

Here’s my problem : yesterday before leave work, meteor was running good; today it doesn’t want to start, here’s the error thrown :

C:\Users\Xob\AppData\Local.meteor\packages\meteor-tool\1.1.10\mt-os.windows.x86_32\dev_bundle\lib\node_modules\fibers\future.js:245
throw(ex);
^
SyntaxError: Unexpected token C
at Object.parse (native)
at getInstalledDependenciesTree (C:\tools\isobuild\meteor-npm.js:437:17)
at updateExistingNpmDirectory (C:\tools\isobuild\meteor-npm.js:208:35)
at Object.meteorNpm.updateDependencies (C:\tools\isobuild\meteor-npm.js:86:7)
at Object.compile (C:\tools\isobuild\compiler.js:118:19)
at C:\tools\isobuild\isopack-cache.js:271:30
at C:\tools\utils\buildmessage.js:356:18
at [object Object]..extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at C:\tools\utils\buildmessage.js:349:34
at [object Object].
.extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at C:\tools\utils\buildmessage.js:347:23
at [object Object]..extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at Object.enterJob (C:\tools\utils\buildmessage.js:321:26)
at [object Object].
.extend.loadLocalPackage (C:\tools\isobuild\isopack-cache.js:227:18)
at C:\tools\isobuild\isopack-cache.js:166:14
at C:\tools\utils\buildmessage.js:356:18
at [object Object].
.extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at C:\tools\utils\buildmessage.js:349:34
at [object Object]..extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at C:\tools\utils\buildmessage.js:347:23
at [object Object].
.extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at Object.enterJob (C:\tools\utils\buildmessage.js:321:26)
at [object Object]..extend.ensurePackageLoaded (C:\tools\isobuild\isopack-cache.js:158:20)
at C:\tools\isobuild\isopack-cache.js:73:14
at C:\tools\packaging\package-map.js:57:7
at Function.
.each.
.forEach (C:\Users\Xob\AppData\Local.meteor\packages\meteor-tool\1.1.10\mt-os.windows.x86_32\dev_bundle\lib\node_modules\underscore\underscore.js:87:22)
at [object Object]..extend.eachPackage (C:\tools\packaging\package-map.js:49:7)
at [object Object].
.extend.buildLocalPackages (C:\tools\isobuild\isopack-cache.js:72:24)
at C:\tools\project-context.js:735:25
at C:\tools\utils\buildmessage.js:356:18
at [object Object]..extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at C:\tools\utils\buildmessage.js:349:34
at [object Object].
.extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at C:\tools\utils\buildmessage.js:347:23
at [object Object]..extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at Object.enterJob (C:\tools\utils\buildmessage.js:321:26)
at ProjectContext.
.extend.buildLocalPackages (C:\tools\project-context.js:734:18)
at C:\tools\project-context.js:257:35
at C:\tools\utils\buildmessage.js:356:18
at [object Object].
.extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at C:\tools\utils\buildmessage.js:349:34
at [object Object]..extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at C:\tools\utils\buildmessage.js:347:23
at [object Object].
.extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at Object.enterJob (C:\tools\utils\buildmessage.js:321:26)
at ProjectContext..extend.completeStagesThrough (C:\tools\project-context.js:247:18)
at ProjectContext.
.extend.saveChangedMetadata (C:\tools\project-context.js:235:10)
at ProjectContext.
.extend.prepareProjectForBuild (C:\tools\project-context.js:240:10)
at C:\tools\runners\run-app.js:517:29
at C:\tools\utils\buildmessage.js:268:13
at [object Object]..extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at C:\tools\utils\buildmessage.js:261:29
at [object Object].
.extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at C:\tools\utils\buildmessage.js:259:18
at [object Object]..extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at C:\tools\utils\buildmessage.js:250:23
at [object Object].
.extend.withValue (C:\tools\utils\fiber-helpers.js:114:14)
at Object.capture (C:\tools\utils\buildmessage.js:249:19)
at bundleApp (C:\tools\runners\run-app.js:516:31)
at [object Object]._.extend.runOnce (C:\tools\runners\run-app.js:594:35)
at [object Object].
.extend._fiber (C:\tools\runners\run-app.js:858:28)
at C:\tools\runners\run-app.js:396:12

I tryed with multiple backups, very old ones enable meteor to start, but the latest version does work even if the exact same code works for my coworker.
I uninstalled/reinstalled meteor twice, I’m running out of solutions…

Thanks for your attention.


#2

I uninstalled/reinstalled meteor twice, I’m running out of solutions…

Have you tried switching to Linux? There’s no problem with Meteor on Linux and you’ll get a decent OS too.


#3

Have you got an incompatible version of node installed separately?


#4

I uninstalled/reinstalled meteor twice, I’m running out of solutions…

This had this problem last week on Linux.

The solution was to
1 - uninstall Meteor
2 - remove the meteor setup files
3 - reinstall Meteor.

The bit you are missing is 2 - the setup files


#5

I don’t think so, I’m working with the heroku toolbelt, I uninstalled/reinstalled/updated it but the problem is the same
I’m currently trying to remove the setup files


#6

Have a look at this: http://stackoverflow.com/questions/15851923/cant-install-update-or-run-meteor-after-update


#7

Unfortunately it didn’t work :confused: