Install and use meteor on an intranet network with no internet connection


#1

Hi everybody,

I need some help in installing meteor on an computer thats part of an intranet network with no internet connection.
The only thing I can do is to download files on a computer that does have internet connection, burn the files to a disc, and then copy them from the disc to the computer with no internet connection.
I tried downloading the installer from meteor site (the windows one - Im using windows OS),
but the installer gotta have internet connection cause it downloads the files for the installation.
any ideas on how can I do that??

Thanks


#2

Hi Maory,
I did the same as you stated few weeks ago, on a disconnected network and it it worked without any issues.
It’s weired…
Anyway , I might have a workaround for you. Please try the following:

  1. Install meteor on the computer with an internet connection, create there a sample application, and add to it all the extra packages that you currently need.
  2. Copy the following folders and add them to your disconnected computer:
  • The meteor folder, where you created your sample app
  • .meteor folder (usually in windows its under C:\Users\ username\AppData\Local)
  1. In the future, if you will want to add additional packages, I recommend you to first add them to your sample application in the computer that is connected to an internet (using “meteor add packagename”). It will add the actual package with the proper configuration to the .meteor\packages folder. In addition, it will add a reference to the package inside your app folder, under the packages file.
    Burn the new package relevant folder and add it to your disconnected network to the same location. Then, in the disconnected computer, go to your real app location and write "meteor add packagename. Since the package already exists there, it will add a reference to the package in your packages file.
    It should do the work.

Let me know if it doesn’t work for you and I’ll try to search for another workaround.
Good luck!


#3

First of all, thank you for your help! Great solution!

But about the regular windows installer that worked for you, did you mean you just copied the installer to the disconnected compute, execute it and it just worked??
Weird! Because the installer first downloads the files it needs for the installation and of course its not possible on the disconnected computer.
Anyways i’ll try the other solution you offered and i’ll post here if it works or not.

Again - thank you for your help!


#4

Hi Maory,
You were correct!
I checked the installation file we originaly downloded (at the end of April this year)- it was 64 MB.
The installation file that is currently downloaded from their website is ~1MB.
It seems that they decided to make a thin installer that will work directly with the internet.
I recommend you ask them to add a full download file version in addition to the current installer (maybe as a feature request).
I will support your request, since we’ll require this ability as well in the future.
Keep me updated!


#5

Hi,

I’m having trouble extracting the files from the disc to the disconnected computer. I keep getting the “destination name too long” error from windows… I guess it is because there are a lot of sub folders… tried to do anything… create the folders my self and then copy the files, but even so I can only create subfolders with limited depth.
anyways I would love it if someone can send me a link to the full installation (even from an older version of meteor).

thanks


#6

It’s frustrating…
And sure, I’ll send you the previous full version as soon as I get to the office (will take me few days)
Please send me your email address.
Thanks.


#7

hi tamaramit,

I actually managed to install meteor on the disconnected computer, and managed to get my app up and going, So thanks again for your help!
But now I try to add additional packages, I first added them to the sample app on the connected to internet computer, then burned the relevant packages folders, copied them to .meteor\packages in the disconnected computer, and tried to add them to my app.
But unfortunately it doesn’t work! I get an error saying
"error: getaddrinfo ENOTFOUND

Your package catalog may be out of date.
Please connect to the internet and try again"

Does it mean I have to copy the entire .meteor folder again??

Thanks.


#8

Hey,
From the error it sounds like not all the project packages were fully downloaded from the internet and it tries to connect and download some additional material.
Does it happen to you with all kind of packages or maybe it’s a specific one that requires somehow an open connection to the internet?
If you try to do it with another package, i.e. underscore, does it show the same error?

When I do it, I run the app on the internet network, then write “meteor add XXX” when I am connected, working on a test project to see that it’s working and then burn only the relevant packages and add them to the disconnected one.
Can you please elaborate if you do the same?

Regarding the catalog, I do see a notification that states that it’s unable to update package catalog (might be related to the package specific version), however it adds it to the packages file and I can work with it with no issues so far.

Attached is a sample screen of the addition from a computer that was disconnected from the network, hope it may help also.

Please let me know how it goes


#9

I opened an issue regarding the offline installation:


#10

OK… so now that my app is up and running on my computer, I want to deploy it on an intranet server, how do I do that?

Thanks,
Maor


#11

so I ran ‘meteor build’ got my node app, copied it to my server (which ofcourse has node installed on), and followed the README notes:

$ (cd programs/server && npm install)
$ export MONGO_URL=‘mongodb://user:password@host:port/databasename’
$ export ROOT_URL=‘http://example.com
$ export MAIL_URL=‘smtp://user:password@mailhost:port/’
$ node main.js,

but unfortunately my server is not connected to the internet so npm install fails, and I get "cannot find module ‘fibers’ " error when I try to run the app.
any thoughts on how can I do it?
maybe I need to use ‘meteor build’ differently? (I used the --directory flag).
HELP please!! :wink:


#12

I don’t normally respond to dead posts but I am running into this issue.

I found the answer here: http://stackoverflow.com/questions/11295050/how-to-install-npm-g-on-offline-server

I’m going to bundle the dependancies into a tar and install locally on demand. I’m using offline-npm with a json file and making an installer.