Installation of accounts-facebook does not work in 1.12

Hey Meteor-Community!

When I want to “meteor add accounts-facebook”, I get the following error message:

While selecting package versions:
error: No version of facebook-oauth satisfies all constraints: @=1.6.0, @~1.7.4
Constraints on package “facebook-oauth”:

  • facebook-oauth@=1.6.0 <- top level
  • facebook-oauth@~1.7.4 <- top level
  • facebook-oauth@1.5.0 <- accounts-facebook 1.3.2

I mean, facebook-oauth was updated to new facebook v8 api, but accounts-facebook wasn’t considered??? Or what am I doing wrong?

What I did was, that I uninstalled accounts-facebook, updated 1.8 to 1.12 and tried to install it again.

Thank you in advance. Best wishes.

What is your facebook-oauth version in app/.meteor/versions ?
Did you run a meteor update --all-packages?

Thanks, in fact, that helped. I haven’t remarked, that I had a local version 1.6 of facebook-oauth, after deleting this one, I could grab version 1.7 together with the new version of accounts-facebook.

Thx and happy new year!

Great to hear that. I think you could now mark the topic as [SOLVED]