iOS Cordova app not loading collection data?

When I enter meteor run ios-device my app compiles & runs but the collection data never loads.

Not getting an error message in the Xcode console, it says:

2017-03-15 17:45:53.552627 sfg[943:239596] CDVWKWebViewEngine will reload WKWebView if required on resume
2017-03-15 17:45:53.552705 sfg[943:239596] Using WKWebView
2017-03-15 17:45:53.553160 sfg[943:239596] [CDVTimer][handleopenurl] 0.151038ms
2017-03-15 17:45:53.555221 sfg[943:239596] [CDVTimer][intentandnavigationfilter] 1.987994ms
2017-03-15 17:45:53.555347 sfg[943:239596] [CDVTimer][gesturehandler] 0.057995ms
2017-03-15 17:45:53.693700 sfg[943:239596] Serving asset bundle version: a687763d4c97104b43d088a37ef08859fe180114
[INFO] GCDWebServer started on port 12680 and reachable at http://localhost:12680/
2017-03-15 17:45:53.698463 sfg[943:239596] [CDVTimer][webapplocalserver] 143.001020ms
2017-03-15 17:45:53.706901 sfg[943:239596] [CDVTimer][statusbar] 8.319020ms
2017-03-15 17:45:53.741417 sfg[943:239596] [CDVTimer][splashscreen] 34.393013ms
2017-03-15 17:45:53.741534 sfg[943:239596] [CDVTimer][TotalPluginStartup] 188.562989ms

I assume this issue is a problem with the app talking to the local server, as the meteor run message warns:

You are testing your app o a remote device. For the mobile app to be able to connect to the local server, make sure your device is on the same network, and that the network configuration allows clients to talk to each other (no client isolation).

I’ve tried running with the --mobile-server= command, e.g. meteor run ios-device --mobile-server= but that had no effect.

If I run meteor run ios-device but then pick a simulator in Xcode instead of my plugged-in iPhone, it works fine, the data loads. Only when I run it on my iPhone does the data in the app not load.

In my mobile-config.js file I have:


But that seems to have no effect either. This seems like some kind of permissions/access issue, but if I go to from another computer in the network the app loads fine.

Any ideas what this could be? Or what other diagnostic tool I could use to figure out what’s causing this?

OK, never mind. I just changed the --mobile-server=(server) to a different, public version of the app I have set up and it worked fine.

Keep calm and carry on.