iOS Simulator won't load Meteor app anymore


#1

When I do meteor run ios, I just get the splash screen indefinitely:

I’ve done meteor reset more than once to clear out the caches and Cordova build. I can’t figure out what’s going on. Is there some way to troubleshoot this, see logs or anything like that?


#2

Ahh, good ol’ “Reset Content and Settings” from the Simulator menu did the trick!


#3

Ok, not solved after all. @sashko - any ideas?


#4

Not my domain - maybe @martijnwalraven?


#5

Bah. Ok… it was being caused by a plugin, specifically cordova-plugin-wkwebview. Which I had installed because I found a weird bug (either with Cordova or the React tap event plugin) where if you have a list of items in a div that has WebkitOverflowScrolling to touch (momentum scroll) and you flick the list, tapping on an item brings up the wrong item detail page. It’s like the tap’s placement is being incorrectly tracked.

Once I removed the WKWebView plugin, the app now loads up fine.


#6

Are you running Meteor 1.2.1? The version of Cordova iOS that it bundles doesn’t support cordova-plugin-wkwebview. We just released a first beta of the Cordova improvements coming in Meteor 1.3 however, which uses WKWebView by default.

In general, to track problems like this down:

  • View the logs from native code in Xcode
  • Use remote debugging in Safari to view logs in the web console

#7

Oh, I’m using Meteor 1.3. So I’m all set? I already checked logs and debugged as much as I can. I think it may be a bug with the React tap event plugin.


#8

Well, Meteor 1.3 gives you WKWebView by default. Do I understand correctly you also added cordova-plugin-wkwebview manually? There might be a version conflict there if you tried to install an older version, perhaps something we should check against.

There may also be differences between UIWebView and WKWebView that components may need to take into account. But what I don’t understand is how the WebkitOverflowScrolling problem means the app will hang on the splash screen?


#9

Er, sorry. Just to clear things up: it was the inclusion of the wkwebview plugin that caused the app to hang. Once I removed it, it works fine. The touch bug is a separate thing.


#10

Which version of cordova-plugin-wkwebview were you trying to add? Can you check to see if you are still running on WKWebView?


#11

I tried both 0.6.0 and 0.6.7, both failed to work in Meteor 1.3, iOS 9.2. I removed the plugin since it was preventing the app from getting past the splash screen. What specifically do you want me to check?


#12

Hmmm, I think we’re not actually talking about the same plugin. I meant the official cordova-plugin-wkwebview-engine plugin, which is currently at version 1.0.1. There should be log output in Xcode telling you whether you are running on WKWebView (but I wouldn’t know why that wouldn’t be the case, unless there is a really weird interaction with another plugin).


#13

@ffxsam did you ever figure this out?