Issue while executing npm


#1

Hi everyone !
Im using below versions for my meteor application :
meteor version 1.4.1.2
node version v0.12.7

In order to build application, i run:
npm config set msvs__version 2015 --global which executed fine.
Now , when im using npm install , it gives me following error : LINK : fatal error LNK1104: cannot open file 'MSCOREE.lib’

Did some research on this , but issue still remain.
Will be grateful if someone can give pointers/suggestions on how to resolve this issue !

Im also attaching complete error trace for reference and better understanding.



Thanks & Regards,
Mayank


#2

If you’re using Meteor 1.4.1.2 you should be using Node v4.5.0. Also, when running the npm command, prefix it with meteor to make sure you’re using the version of npm Meteor has been tested with. E.g.:

meteor npm install

#3

Hello,
I updated to Node v4.5.0 and tried running both npm commands mentioned above prefixing meteor, but result is still same.
looking at error trace, seems issue with node-gyp rebuild.
Any suggestions will be appreciated here!

Thanks,
Mayank


#4

Try running:

npm install --global --production windows-build-tools