Issue with cordova-plugin-meteor-webapp after upgrade to Meteor 1.3

HI, I am getting the following issue after upgrading to Meteor 1.3:

=> App running at: http://localhost:3000/     
=> Errors executing Cordova commands:         
   While running Cordova app for platform iOS with options --emulator:
   Error: Command failed: /Users/adamginsburg/Documents/Development/buzzy7/.meteor/local/cordova-build/platforms/ios/cordova/run --emulator
   The following build commands failed:
   CompileSwift normal i386 /Users/adamginsburg/Documents/Development/buzzy7/.meteor/local/cordova-build/platforms/ios/Buzzy/Plugins/cordova-plugin-meteor-webapp/WebAppLocalServer.swift
   CompileSwift normal i386 /Users/adamginsburg/Documents/Development/buzzy7/.meteor/local/cordova-build/platforms/ios/Buzzy/Plugins/cordova-plugin-meteor-webapp/WebAppConfiguration.swift
   CompileSwift normal i386 /Users/adamginsburg/Documents/Development/buzzy7/.meteor/local/cordova-build/platforms/ios/Buzzy/Plugins/cordova-plugin-meteor-webapp/AssetBundleManager.swift
   CompileSwift normal i386 /Users/adamginsburg/Documents/Development/buzzy7/.meteor/local/cordova-build/platforms/ios/Buzzy/Plugins/cordova-plugin-meteor-webapp/AssetBundle.swift

I did try and add/remove “webapp” any ideas pls?

Which version of Xcode do you have installed? Could you try meteor run ios-device and run the app from Xcode? That should give you more information about compile errors.

Wait, why do you have cordova-plugin-meteor-webapp installed under Buzzy/Plugins? Have you somehow installed the plugin yourself?

Hi, thanks

Xcode version is 7.3 (7D175)
I had tried running vis ios-device and ios
I had “webapp” installed, is the how cordova-plugin-meteor-webapp Phew can’t remember why I had it installed… may have been hangover of old old cordova work. I uninstalled webapp but issue persists. Letme know if I need to clean up?

When I run in X-code I get a different error… will past here in a sec.

This is what I see in the XCode left hand side panel/window

Not sure why it would be missing CordovaLib, but that is definitely not good. Could you try rm -rf .meteor/local in your app directory and rebuild?

Thanks. I did the rm -rf .meteor/local
When I run meteor run ios I it says it started the app on the emulator… but it’s not there.

When I run via XCode and click the option to run on the emulator from there it works.

When I run meteor run ios-device that works too… so seems to be partially fixed. Not sure if I have to restart or something to get it meteor run ios to work?

One thing I did notice is the app seems to use the local ip address now, not “localhost”. Does this mean I have set the ROOTURL to localhost? Just that a lot of Oauth systems etc are setup to allow localhost to work.

Not sure why the emulator wouldn’t work with meteor run ios. You may have to quit the emulator and let it be reopened, if it somehow got stuck.

You don’t have to set ROOT_URL during development, and you would set it to your actual server URL when deploying to a remote server. You may indeed have to set your OAuth callback URL, but note that you always needed to do that when running on a device.

Thanks I rebooted after running rm -rf .meteor/local and it now works. Thanks again for your help.

BTW, getting another issue with windows not opening on Cordova - I will start another thread on that.

Hey guys,

I’m running into the same issue and I’ve tried everything above and then some.

The error I get when I run meteor run ios:

The following build commands failed:
CompileSwift normal i386
CompileSwift normal i386

when i run meteor run ios-device

I’m running XCode 8.0 Beta

Thanks in advance.

Any luck with this? I got the same errors as adefadeyibi

More info at Stack Overflow Thread

Also, it’s the same as this GitHub Issue

For now, see the instructions here to update to the Swift 3 version of the Meteor Cordova plugin.

1 Like

I just updated the project to Meteor to fix the blocked connections error in iOS 10 and now i have this error. The link to “Swift 3 version of the plugin” is no valid anymore as there is one master branch only.
I tried putting cordova-plugin-meteor-webapp@1.4.1 to the cordova-plugins list, but still have same gazillion of errors like /Plugins/cordova-plugin-meteor-webapp/Errors.swift:15:11: enum case 'unsuitableAssetBundle' not found in type 'WebAppError'. I searched all around, but it’s really hard to find anything in these forums and git issues…
Can anyone show an official normal way to build for iOS? Is it in meteor guides? Anywhere?