Issues with SSL and Meteor Up?


#1

I’m trying to update a repo already on Digital Ocean to now use https that is deployed using Meteor Up. When I add the ssl section as defined here, the deploy is successful but visiting the https site fails. Has anyone encountered this before? Any tips for how to fix it? On the MUP Github, I see people have asked about this before but to no answer.


#2

Has worked perfectly fine for me – can you show us your mup file? (excluding sensitive information, of course)


#3

Here’s how my mup.js file is currently structured.

module.exports = {
  servers: {
    one: {
      // TODO: set host address, username, and authentication method
      host: ‘IPADDRESS’,
      username: ‘USERNAME’,
      password: ‘PASSWORD’,
      // pem: '~/.ssh/id_rsa'
      // or neither for authenticate from ssh-agent
    }
  },

  meteor: {
    // TODO: change app name and path
    name: ‘APP-Name’,
    path: '/Users/path/to/file’,

    servers: {
      one: {},
    },

    buildOptions: {
      serverOnly: true,
    },

    env: {
      // TODO: Change to your app's url
      // If you are using ssl, it needs to start with https://
      ROOT_URL: 'https://website.com’,
      MONGO_URL: 'mongodb://localhost/meteor',
      MAIL_URL: 'smtps://MAILURL@smtp.mailgun.org:587',
    },

     ssl: { 
      // Enables let's encrypt (optional)
       autogenerate: {
        email: 'team@domain.com’,
        // comma seperated list of domains
        domains: ‘domain,www.domain.com'
       }
    },

    docker: {
      // change to 'kadirahq/meteord' if your app is not using Meteor 1.4
      image: 'abernix/meteord:base',
      // imagePort: 80, // (default: 80, some images EXPOSE different ports)
      prepareBundle: false,
    },

    // This is the maximum time in seconds it will wait
    // for your app to start
    // Add 30 seconds if the server has 512mb of ram
    // And 30 more if you have binary npm dependencies.
    deployCheckWaitTime: 300,

    // Show progress bar while uploading bundle to server
    // You might need to disable it on CI servers
    enableUploadProgressBar: true
  },

  mongo: {
    port: 27017,
    version: '3.4.1',
    servers: {
      one: {}
    }
  }
};