Issues with updating Meteor/Materialize

#1

Our software is hosted on mLab and they have the mandatory database upgrade on Tuesday, so I’m upgrading our deployment to make sure we’re ready in preparation.

I’ve gotten Meteor to update, but I’m having a lot of trouble with Materialize.

I had to remove Materialize to even get the Meteor update to complete.

Now I try to add the materialize:materialize package from atmosphere again and it doesn’t work.

I’ve had absolutely no luck with the NPM package install either. The SCSS imports are not able to find the include directory, even though I have fourseven:scss installed properly. I’m wondering if there may be a bug or mismatch in versions, but I haven’t found anyone with this issue (at least in the last year, some older versions had issues).

I tried manually adding the script/css file to head, and that works for some elements, but it seems that the scripts are not working correctly as the console in the browser is giving many errors. I’m assuming this is due to jquery mismatching.

I’ve tried poetic/materialize and had no luck.

I’m not sure what to do at this point, but I only have tomorrow and Monday to figure this out so I’m getting a bit worried. I’m not sure what other options I have at this point.

Has anyone got materialize to work with recent versions of Meteor on an existing project?

#2

you can use Materialize without installing materialize:materialize meteor package.
I have a sample repository at https://github.com/minhna/meteor-react-ssr.
Good luck.

#3

Thanks for the response!

Sorry I should have noted that my project isn’t a React project.

But I will take a look at the repository and check the Materialize implementation! I’ll post back if success or any issues!

#4

I’m getting the error:

   error: Scss compiler error: Error: _includePaths is not
   iterable
   on line 2 of {}/client/main.scss
   >> @import 'materialize.scss';

I don’t know if it’s related to this: https://github.com/Meteor-Community-Packages/meteor-scss/issues/289

Any ideas?

(Edit: realized scss-config.json was missing. Above issue is fixed, but now have a different issue:

It’s partially loading up now, but some elements are still not rendering correctly. Particularly sidebars and selects.

I’m getting errors such as:

TypeError: $(...).form_select is not a function

Doesn’t seem the Javascript is initializing correctly.

Also tables don’t seem to be rendering correctly.

This is similar to issues I’ve had with my other attempts at installing. I’m not sure how to resolve,

The only part that seems to be working as intended is the column/responsiveness.

#5

It looks like jquery issue.

#6

Hi. Which version of materializecss do you use (v0.100.2 or v.1.0.0) ?
The initialization process is not the same for form select in both version :
For v1.0.0:

$(document).ready(function(){
    $('select').formSelect();
  });

For v.0.100.2:

$(document).ready(function() {
    $('select').material_select();
  });

I hope the above helps …

#7

In that repository, I use v1.0.0 of metarialize-css

#8

ok. In your post, you mention :

$(...).form_select

From the documentation, you should use

$('select').formSelect();

to initialize