Just an FYI: Bash on Windows 10 now available


#1

For Windows Insiders on the Fast Ring at least. Currently in the process of installing the new build. I’ll try to see how Meteor and this Ubuntu on Windows work together (and whether they do at all).


#2

Really curious to see how this works with Meteor!


#3

I’ll happily sacrifice myself so you poor sodsfine people on Linux don’t have to!


#4

Still some way to go, it seems:

That’s directly after a plain curl https://install.meteor.com/ | sh

The symlinks strike again! Or so it seems.

A quick ln -s ./existing_directory test_directory yields:

ln: failed to create symbolic link 'test_directory': Operation not permitted

Same when running the starting bash from an elevated cmd.


#5

Okay, installing Node from sources bombs out somewhere (I’m not able to discern the exact issue because it just says: Invalid Argument somewhere while compiling), doing an apt-get install node also has some problems.

But apt-get install npm works (and yields version 1.3.10)


#6

If symlinks don’t work, that would be a huge bummer. It’s one of the biggest issues with Meteor on Windows.


#7

It’s most probably due to the fact that symlinks work differently on NTFS than under the various Linux filesystems. And when you start out in Windows, you only have NTFS or FAT as options, the latter of which does not support symlinks at all.

I’ll see if I can accomplish something with an ext2/3/4 partition.


#9

It’s still really early days with this stuff. Pretty sure they won’t waste their efforts on all this and not find a way to allow symlinks :slight_smile:


#10

As I said, it’s most likely a problem with the underlying file system (i.e. NTFS). And probably not that easily solved.


#11

Okay, looks like Ext2/3/4 is a no-go. Because I’d like to have native access which means a driver which means Paragon’s ExtFS.

Which states, however:

Paragon HFS+ for Windows has got a number of limitations, which however are going to be fixed in the nearest future:
 No support for resource forks;
 No support for symbolic links and hard links;
 No support for ACL (Access Control List).

Can you spot the problem?


#12

There’s an app called Bash on Ubuntu on Windows and in there you can do symlinks but only if you don’t go into the /mnt folder which renders it a bit pointless. Note you will always be “root” when you run that app.

My guess is that it’s a base Ubuntu environment in a loopback file system (as I can’t find the actual files for it yet). The shell is pretty limited and it can’t run Windows apps even command line ones from there.

However, when installing Meteor by curl it gives an error about not being able to creat a symlink, but I am not sure where it is trying to create it as the env results do not show anything in mnt.


#13

Not exactly sure if it was because of the bash install or not, but the command-line for Meteor is all out of whack right now.


#14

Yeah. It does that under Powershell, too. Moderately annoying.


#15

But I am pretty sure it didn’t do that before this Insider Build before right?


#16

Indeed. But I can’t check it due to the lack of non-insider PCs at my home :slight_smile:


#17

Updated Windows 10 to the more current insider preview. Still no luck, I even removed the Linux integration.


#18

I have been seeing the same issue. For now, you can open properties of the command shell window, then check the last option which is “Use legacy console” This does require a relaunch of the shell.


#19

Maybe we need to open up a bug on meteor/meteor on this. Gulp does not have any issue. Any other apps aside from meteor you noticed this?


#20

No issues with any other app other than meteor. However, I am running Windows 10 Insider Preview builds which are ideally not production ready. Not sure, if it works fine with stable Windows 10 builds.


#21

It should be. There is no option for “legacy” command prompt in standard Windows 10 machines.