Just an FYI: Bash on Windows 10 now available

It’s most probably due to the fact that symlinks work differently on NTFS than under the various Linux filesystems. And when you start out in Windows, you only have NTFS or FAT as options, the latter of which does not support symlinks at all.

I’ll see if I can accomplish something with an ext2/3/4 partition.

1 Like

It’s still really early days with this stuff. Pretty sure they won’t waste their efforts on all this and not find a way to allow symlinks :slight_smile:

1 Like

As I said, it’s most likely a problem with the underlying file system (i.e. NTFS). And probably not that easily solved.

Okay, looks like Ext2/3/4 is a no-go. Because I’d like to have native access which means a driver which means Paragon’s ExtFS.

Which states, however:

Paragon HFS+ for Windows has got a number of limitations, which however are going to be fixed in the nearest future:
 No support for resource forks;
 No support for symbolic links and hard links;
 No support for ACL (Access Control List).

Can you spot the problem?

There’s an app called Bash on Ubuntu on Windows and in there you can do symlinks but only if you don’t go into the /mnt folder which renders it a bit pointless. Note you will always be “root” when you run that app.

My guess is that it’s a base Ubuntu environment in a loopback file system (as I can’t find the actual files for it yet). The shell is pretty limited and it can’t run Windows apps even command line ones from there.

However, when installing Meteor by curl it gives an error about not being able to creat a symlink, but I am not sure where it is trying to create it as the env results do not show anything in mnt.

Not exactly sure if it was because of the bash install or not, but the command-line for Meteor is all out of whack right now.

Yeah. It does that under Powershell, too. Moderately annoying.

But I am pretty sure it didn’t do that before this Insider Build before right?

Indeed. But I can’t check it due to the lack of non-insider PCs at my home :slight_smile:

1 Like

Updated Windows 10 to the more current insider preview. Still no luck, I even removed the Linux integration.

I have been seeing the same issue. For now, you can open properties of the command shell window, then check the last option which is “Use legacy console” This does require a relaunch of the shell.

1 Like

Maybe we need to open up a bug on meteor/meteor on this. Gulp does not have any issue. Any other apps aside from meteor you noticed this?

No issues with any other app other than meteor. However, I am running Windows 10 Insider Preview builds which are ideally not production ready. Not sure, if it works fine with stable Windows 10 builds.

It should be. There is no option for “legacy” command prompt in standard Windows 10 machines.

Update: Everything seems to be working now!

I’ve only heard about Windows 10’s bash today. Installed the bash application, installed meteor, installed node, installed npm. Only minor errors during the the process. Now running meteor on windows with all the code refresh speed of linux.

This should be better publicized somewhere in the Meteor community as it’s one of the biggest criticisms among Windows users. Some more updates here: Linux’s Meteor install now works natively on Windows


Unfortunately, only a tiny fraction of our users are on Windows 10. Perhaps this could encourage people to upgrade, but I don’t know if it’s a viable strategy for most people? Maybe we can add something to the website so that people can make the choice themselves.

It’s odd that you needed to install npm and node separately… we should see why that is, since Meteor includes those things.

Hi Sashko, I understand that Windows isn’t as high priority as other platforms. I usually lean towards Linux myself, but I’ve been quite happy with Windows 10 on this laptop, especially if I can run native bash.

No ideia why node/npm have to be installed separately. I was also under the impression meteor included them.

Another curious error is when I run meteor through bash, even though it runs fine, I receive a warning before MongoDB starts message saying:
Your development database is using mmapv1, the old, pre-MongoDB 3.0 database engine. You should consider upgrading to Wired Tiger, the new engine. The easiest way to do so in development is to run meteor reset. If you'd like to migrate your database, please consult https://docs.mongodb.org/v3.0/release-notes/3.0-upgrade/

This message does not show up when I run meteor through Windows. If I perform a meteor reset through bash, it seems the database engine is upgraded, since the warning does not show up anymore, but MongoDB becomes unable to start (both in bash and windows). While starting meteor project, during MongoDB start I receive an “unexpected mongo exit” error.

If I perform another meteor reset, this time on windows, the engine seems to be reverted (I start receiving the engine related warning messages on bash) but everything else works properly.

Oh, Windows users are definitely a priority by the way. I just meant most of our users on Windows are running Windows 7 or 8, not 10.

1 Like

When using powershell to run meteor the cmd line interface gets distorted but the meteor app runs. Hope it is fixed. So now I went back to the basic command line (cmd) and it works. Perhaps I will install bash

I use Windows 10 please continue to support us. Meteor thus far works well on windows.

1 Like