Kadira debug doesn't work here


#1

Hi.
I would like to try kadira debug in my app, but I can’t get it to works.
I add the kadira:debug package in my app, and when I launch, I got this full stack bellow.
And when I tried to connect on http://localhost:3000 on the http://debug.kadiraio.com/debug, it’s saying “Waiting for connection…” for hours ! :frowning:

I tried to use older package like meteorhacks:kadira@2.21.0, but this time this is the kadira debug website who are saying I not using the last package’s version.

What I did wrong ?

/home/pierre/.meteor/packages/meteor-tool/.1.3.2_4.1xgc186++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/server-lib/node_modules/fibers/future.js:300
						throw(ex);
						      ^
Error: corrupt bson message < 5 bytes long
    at Object.Future.wait (/home/pierre/.meteor/packages/meteor-tool/.1.3.2_4.1xgc186++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/server-lib/node_modules/fibers/future.js:420:15)
    at MongoConnection._createCappedCollection (packages/mongo/mongo_driver.js:263:10)
    at OptimizedApply (packages/meteorhacks_kadira/packages/meteorhacks_kadira.js:267:1)
    at Object.ret.(anonymous function) [as _createCappedCollection] (packages/meteorhacks_kadira/packages/meteorhacks_kadira.js:2881:1)
    at [object Object].Mongo.Collection._createCappedCollection (packages/mongo/collection.js:682:20)
    at new KdDataLayer (packages/kadira_debug/lib/server/data_layer.js:10:1)
    at Package (packages/kadira_debug/lib/server/connect.js:24:1)
    at packages/kadira_debug/lib/server/connect.js:267:1
    at packages/kadira_debug/lib/server/connect.js:267:1
    at /home/pierre/Documents/projects/garandeau/hs6_new/intranet/WebstormProjects/IT7_Meteor/.meteor/local/build/programs/server/boot.js:283:10
    - - - - -
    at Function.BSON.deserialize (/home/pierre/.meteor/packages/npm-mongo/.1.4.43.1wm7q3r++os+web.browser+web.cordova/npm/node_modules/mongodb/node_modules/bson/lib/bson/bson.js:1192:31)
    at BSON.deserialize (/home/pierre/.meteor/packages/npm-mongo/.1.4.43.1wm7q3r++os+web.browser+web.cordova/npm/node_modules/mongodb/node_modules/bson/lib/bson/bson.js:1494:15)
    at [object Object].MongoReply.parseBody (/home/pierre/.meteor/packages/npm-mongo/.1.4.43.1wm7q3r++os+web.browser+web.cordova/npm/node_modules/mongodb/lib/mongodb/responses/mongo_reply.js:60:34)
    at [object Object].<anonymous> (/home/pierre/.meteor/packages/npm-mongo/.1.4.43.1wm7q3r++os+web.browser+web.cordova/npm/node_modules/mongodb/lib/mongodb/connection/server.js:446:20)
    at [object Object].emit (events.js:95:17)
    at [object Object].<anonymous> (/home/pierre/.meteor/packages/npm-mongo/.1.4.43.1wm7q3r++os+web.browser+web.cordova/npm/node_modules/mongodb/lib/mongodb/connection/connection_pool.js:207:13)
    at [object Object].emit (events.js:98:17)
    at Socket.<anonymous> (/home/pierre/.meteor/packages/npm-mongo/.1.4.43.1wm7q3r++os+web.browser+web.cordova/npm/node_modules/mongodb/lib/mongodb/connection/connection.js:440:22)
    at Socket.emit (events.js:95:17)
    at Socket.<anonymous> (_stream_readable.js:765:14)
Exited with code: 8
Your application is crashing. Waiting for file change. 

Thanks.


#2

Noone is using kadira debug anymore ?


#3

hey man it did this to me before the first time I used it.

Just restart your app, make sure the kadira debug is turned on and initialized in the console where you issue meteor and then open the debug url. Sometimes its a bit flaky and needs a couple attempts to get it to work but it does and then gives you some very rudimentary information regarding execution and so. I find using debug and breakpoints far more productive.


#4

Thanks for you reply tomtom87.

I attempted to update my meteor to get the meteor-tool@1.3.3.
Then I readd the package from my console.

$meteor add kadira:debug
                                              
Changes to your project's package version selections:
                                              
kadira:debug         added, version 3.2.2     
kadira:runtime-dev   added, version 0.0.1
meteorhacks:kadira   added, version 2.23.4
meteorhacks:meteorx  added, version 1.3.1
                                       
kadira:debug: Full Stack Debugging Solution for Meteor

No problem there. Trying then to launch meteor from there but I still get this error stack. When I remove the package I can launch meteor without any problems !
The proxy started, the build worked, but the stack is coming after the message “starting your app”.

You said : “make sure the kadira debug is turned on and initialized in the console”, how can I do this ?


#5

Yeh its well confusing, not very well thought out design by kadira really. You have to go on the kadira website, then click on the debugger part. Then you must start the app, cross your fingers, go in and out of the room 3 times, maybe check the sun is at the right degrees and say hail jesus and if you did it right it will show you about 3 or 4 ‘debug’ entries, things usually about Kadira, then it will show you some publications. It’s quiet an anti-climax. Node debugger is alot easier imo…