Kadira Meteor-Up / MUPX - Verifying Deployment: FAILED

Hello, I’m trying to deploy a Meteor 1.2.1 basic project using Kadira Meteor-Up (https://github.com/kadirahq/meteor-up) to fresh Ubuntu 14.04 x64 vmlinuz-3.13.0-71-generic (digitalocean) droplet and i’ve got following error:

MBP-Mateusz:magnus mzygmunt$ mup deploy
Bulding App Bundle Locally
Started TaskList: Pushing Meteor
[] - Pushing Meteor App Bundle to The Server
[] - Pushing Meteor App Bundle to The Server: SUCCESS
[] - Pushing the Startup Script
[] - Pushing the Startup Script: SUCCESS

Started TaskList: Configuring  Meteor Environment Variables
[] - Sending Environment Variables
[] - Sending Environment Variables: SUCCESS

Started TaskList: Start Meteor
[] - Start Meteor
[] - Start Meteor: SUCCESS
[] - Verifying Deployment
[] x Verifying Deployment: FAILED
    to the latest stable version, run:
    npm WARN deprecated 
    npm WARN deprecated   npm -g install npm@latest
    npm WARN deprecated 
    npm WARN deprecated (Depending on how Node.js was installed on your system, you
    npm WARN deprecated may need to prefix the preceding commands with `sudo`, or if
    npm WARN deprecated on Windows, run them from an Administrator prompt.)
    npm WARN deprecated 
    npm WARN deprecated If you're running the version of npm bundled with
    npm WARN deprecated Node.js 0.10 LTS, be aware that the next version of 0.10 LTS
    npm WARN deprecated will be bundled with a version of npm@2, which has some small
    npm WARN deprecated backwards-incompatible changes made to `npm run-script` and
    npm WARN deprecated semver behavior.
    npm WARN package.json meteor-dev-bundle@0.0.0 No description
    npm WARN package.json meteor-dev-bundle@0.0.0 No repository field.
    npm WARN package.json meteor-dev-bundle@0.0.0 No README data
    => Starting meteor app on port:80
    To see more logs type 'mup logs --tail=50'
at /Users/mzygmunt/Desktop/custom_npm/meteor-up/node_modules/nodemiral/lib/coreTasks.js:39:16
at /Users/mzygmunt/Desktop/custom_npm/meteor-up/node_modules/nodemiral/lib/session.js:146:9
at Channel.<anonymous> (/Users/mzygmunt/Desktop/custom_npm/meteor-up/node_modules/nodemiral/lib/ssh.js:125:9)
at emitOne (events.js:90:13)
at Channel.emit (events.js:182:7)
at SSH2Stream.<anonymous> (/Users/mzygmunt/Desktop/custom_npm/meteor-up/node_modules/ssh2/lib/Channel.js:124:14)
at SSH2Stream.g (events.js:273:16)
at emitNone (events.js:80:13)
at SSH2Stream.emit (events.js:179:7)
at parsePacket (/Users/mzygmunt/Desktop/custom_npm/meteor-up/node_modules/ssh2-streams/lib/ssh.js:3435:10)
at SSH2Stream._transform (/Users/mzygmunt/Desktop/custom_npm/meteor-up/node_modules/ssh2-streams/lib/ssh.js:552:13)
at SSH2Stream.Transform._read (_stream_transform.js:166:10)
at SSH2Stream._read (/Users/mzygmunt/Desktop/custom_npm/meteor-up/node_modules/ssh2-streams/lib/ssh.js:213:15)
at SSH2Stream.Transform._write (_stream_transform.js:154:12)
at doWrite (_stream_writable.js:292:12)
at writeOrBuffer (_stream_writable.js:278:5)

The problem occurs also in MUPX (https://github.com/arunoda/meteor-up/tree/mupx#). Does anyone have an idea to solve the problem?

sry i didn’t take a look at the source, but in non-kadirahq mup/x
x Verifying Deployment: FAILED
is caused by a too low “deployCheckWaitTime” in most cases.
Simply increasing this time solved it for me.


Thank you for reply, but I increased deployCheckWaitTime to 200 and still not working.

Errors were related with a damaged version of NodeJS. Complete reinstallation of NodeJS definitively resolved the issue.

Note: If you using the Kadira Meteor-Up, you must place mup.js file in .deploy directory inside of your project.

Do you have any more info about the .deploy dir? I’ve been having mup issues for a few days now. Anything you can share would be really helpful. Thanks!

Here you are step-by-step instruction https://github.com/kadirahq/meteor-up. It works perfectly on my Ubuntu 14.04 and Meteor 1.2.1.