Kadirahq/meteor-up 'No such file'


#1

I’ve used mupx to deploy my stuff but after 1.4 it does not work no more. Popular suggestion is to go with kadirahq/meteor-up and have
dockerImage: ‘abernix/meteord:base’ in the mup.js

I’ve done that and it worked on my local machine (Ubuntu), but not on the production server, there I get:

[localhost] - Pushing Meteor App Bundle to The Server
[localhost] x Pushing Meteor App Bundle to The Server: FAILED
No such file

(it says localhost because after failing remote deploy I tried running it in the specific machine)

I have updated docker, npm and node, the server runs in dev mode using meteor run, but no matter what I do, I just get the message above and have no clue what file it wants to find. It creates the bundles and everything ok, but does not go further.

If I do mup reconfig, I get:

 Started TaskList: Configuring  Meteor Environment Variables 
[localhost] - Sending Environment Variables
[localhost] x Sending Environment Variables: FAILED
	No such file

Versions:

meteor 1.4.1.1
nodejs 4.5.0 (must it be 4.4.7?)
docker 1.12.1
npm 3.10.6

I am probably missing something obvious, but I’m lost.

It authenticates properly, if I give wrong credentials I get another error

mup setup, by the way, gives simply:

Started TaskList: Setup Docker
[localhost] - setup docker
[localhost] - setup docker: SUCCESS

#2

Anyone knows what are the minimum installations needed on a Ubuntu for it to accept a deploy? I have a new, fresh, Ubuntu install and would like to do things right…

Does it need to have Meteor installed? Node? Docker? Npm? If I just push a deploy to it I mean. Is it necessary to have mup on the runtime machine?

Many questions…


#3

I am also getting the same error I configured server and local machine to use node v4.4.7 and still same issue. I was hoping you many have found a solution for this?


#4

I ended up using https://www.npmjs.com/package/mupx-letsencrypt
It works perfectly (note that there are two versions, I use the 1.4+ )

With that, I do not install anything on a fresh server, i just do a fresh install (mini), create a user with sudo, run setup/deploy and it’s there.


#5

Hi @ralof can you share your mup.json file?