Load settings.json file in windows environment variable

hi gurus,

simple question, hard to solve.

How can I set a JSON file in my windows environment variable so I can deloy meteor on my windows node server?

settings.json file:

    "adminEmails": "dfdf@qlik.com",
    "public": {
        "host": "PRESALES1",
        "port": 81,
        "UDC": "OEM_HOST",
        "virtualProxyClientUsage": "meteor",
        "webIntegrationHost": "nlsch-mbj3",
        "webIntegrationDemoPort": 3030,
        "SSBIAppSheetString": "40ef70c9-be76-4844-ac6a-d53195146c85/sheet/puEpZK/state/analysis",
        "SSBIApp": "40ef70c9-be76-4844-ac6a-d53195146c85",
        "IntegrationPresenatationApp": "ce2c6eb5-dc73-44fb-a9f9-11fb2777fdfd",
        "IntegrationPresenatationSelectionObject": "RZuJ",
        "facebook": {
            "clientId": "1754933311453043"
    "private": {
        "host": "PRESALES1",
        "port": 81,
        "certificatesDirectory": "C:\\Users\\mbj\\Documents\\GitHub\\QRSMeteor",
        "notificationURL": "http://nlsch-mbj3:3000/updateSenseInfo",
        "SenseServerInternalLanIP": "PRESALES1",
        "useSSL": false,
        "passphrase": null,
        "authentication": "header",
        "virtualProxy": "hdr",
        "headerKey": "hdr-usr",
        "UDC": "OEM_HOST",
        "headerValue": "PRESALES1\\meteor",
        "isSecure": true,
        "engineHeaders": "UserDirectory=PRESALES1;UserId=Qlik",
        "enginePort": 4747,
        "proxyPort": 4243,
        "google": {
            "clientId": "527202830644-.apps.googleusercontent.com",
            "secret": ""
        "facebook": {
            "clientId": "1754933311453043",
            "secret": ""
        "twitter": {
            "clientId": "9hpf77dh7BhLgwtGeoELT3CLX",
            "secret": ""
        "linkedin": {
            "clientId": "86rpkry91dn41y",
            "secret": ""
        "github": {
            "clientId": "535d2ca6386eeca90d65",
            "secret": ""

thank you very much,


I’ve ONLY been able to get my settings.json running by removing all white spaces.

1 big line.

Even when I deploy to Meteor Galaxy, I have to 1 line the whole darn thing.

Try that, see if it solves your problem.

open a command prompt and do:

start cmd.exe /k "meteor --settings settings_localhost.json"

thank you!

I guess you also have to escape every slash etc. as @robfallows suggested? Did you use any tool for this?

I found this tool, but have to test it this week. Hope I get it to work this time because running the dev client in production takes a lot of processor power…

Oh interesting. I don’t have any slashes in my config thankfully, but I’ll keep that in mind.

I don’t have any tools for this, as my config is really small. I’m also doing most of the work myself, not relying on packages. So it’s all hardcoded in to main.js :slight_smile:

Let us know how you make out and if you find tools.