Max call stack size exceeded error on windows 11

I’m running into a LOT of issues trying to run an open-source meteor application.
Currently, I’m getting the following:

E:\Code\node-on-fhir>meteor run
      throw error;

RangeError: Maximum call stack size exceeded
(Use `node --trace-uncaught ...` to show where the exception was thrown)

I am on Windows 11, and was using Node.JS 16. I uninstalled and re-installed with v14.20.0.

The node-on-fhir project has a .meteor/release file that indicates version 2.7.1… When I run meteor run with 2.7.3 installed, it attempts to download 2.7.1 and then fails with a similar “Max call stack size exceeded”, but from a different file (files.js)

I updated the .meteor/release file to use 2.7.3, which matches my global install of meteor. It doesn’t attempt to download meteor-tools, but still results in a “Max call stack size exceeded”, as shown above.

When I do all of this on an ubuntu VM, it installs/runs without error. I’d really like to figure out why this is broken on my windows VM, though, as that’s my usual workstation.

Are you installing Meteor and Node over Windows 11 or are you using WSL? I use Windows 11 with WSL2 and everything works perfectly (I use Node with nvm).

My goal is to install directly in windows, without using HyperV/WSL with an Ubuntu VM.
I first tried using NVM-for-Windows to use 14.20.0 to install it. Then, when that didn’t work, I removed NVM and installed Node 14.20.0 directly. Still didn’t work.

Are you using GitHub - symptomatic/node-on-fhir: Tech stack for building MACRA and 21st Century Cures compliant webapps.?

It’s actually GitHub - clinical-meteor/node-on-fhir: Tech stack for building MACRA and 21st Century Cures compliant webapps. that I’m using… The symptomatic one is a fork, I believe.

Did you open an issue in this repo to try to get some help there? Not sure if it’s related to Meteor itself