Meteor 1.10.1 not working with jquery 3.x

Hi all,

I’m trying to upgrade jQuery to 3.5.1 as security requirement from client but app doesn’t work.

Have anyone upgrade jQuery to that version and have the solution for it?

Any help would be greatly appreciated, Thanks!

You need to also update the jquery package in your Meteor packages list at .meteor/packages and change it to


By using the exclamation mark you are forcing to use the 3.0.0 Meteor package instead of the 1.0.0 so it will support the latest version of the jquery npm install.

Credits to @coagmano who explained this in some other post, which I somehow can’t find via the search


Thanks for your support. I tried but still get the same error.

Uncaught TypeError: url.indexOf is not a function.

I found the solution to fix this issue but got the other error So i think it belongs to meteor core.

I think this belongs to somewhere in your code, if it would be part of the Meteor core we would all get this error. Can you search in your IDE for this pattern? I think it is likely a try to access a property of a null/undefined object.

Also: do you use jQuery UI? I found multiple problems with jQ 3+ and jQ UI - might help to check that :slight_smile: