Meteor 1.12.1 Assertion `args[1]->IsString()' failed

Having updated an old application I’m maintaining to Meteor 1.12.1 I get the following on meteor run:

/Users/knirirr/.meteor/packages/meteor-tool/.1.12.1.mwgklm.brmz9++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/node[37681]: ../src/node_contextify.cc:655:static void node::contextify::ContextifyScript::New(const FunctionCallbackInfo<v8::Value> &): Assertion `args[1]->IsString()' failed.

Nothing useful has come up from Google and the usual first resort of rm -rf node_modules && npm install has had no effect. My Node version is 12.20.1.
Does anyone have any suggestions on how to proceed with this?

try to erase the app local build under .meteor/local.

Is it in development, production, or both ?

Thanks for the reply.
This is only in development - I’ve not got as far as production yet; I was hoping to update it before dealing with a user’s bug report.
Removing .meteor/local/build hasn’t fixed it, I’m afraid.

from this thread https://github.com/nodejs/node/issues/20325 it seems that it comes from node js.
What os are you on ? do you use a node version manager such as nvm ? check if you have multiple nodejs versions installed on your OS (since it’s related to a node v10 bug).

I had wondered about that one, but I have the node version mentioned above in my PATH, and meteor node gives me: “Welcome to Node.js v12.20.1.” So, I can only assume that it’s not related to the Node 10 bug.
The only other version I appear to have installed (using macOS 10.15.7 & Homebrew) is 15.5.0.

try to remove all node versions. Install nvm and re-install 12.20.1 with it.
Did you also removed the bundle cache from .meteor/local ?

Now running /usr/local/Cellar/nvm/0.37.2/versions/node/v12.20.1/bin/node - still the same problem, I’m afraid.

It’s definitely 12.20.1 that seems to be run, e.g.

$ /Users/knirirr/.meteor/packages/meteor-tool/.1.12.1.mwgklm.brmz9++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/node --version
v12.20.1