Meteor 1.3 and Xcode 8 not getting along


#1

Meteor 1.3 and Xcode 8 do not get along. Lots of Swift errors due to version 3 of Swift but even setting Swift to previous version leaves a number of errors and the project will not build. Workaround is to use Xcode 7 :slight_smile:

Jeff


#2

Same problem here. Have you found any fix other than using Xcode 7?


#3

+1 on this, not able to build running on Xcode 8 even with legacy swift set to YES.

Now that iOS 10 has been released and Xcode 8 isn’t in beta anymore, is there any progress to report on this from Meteor?


#4

My experience is that after upgrading to xCode my builds are not properly running on iOS10 devices. The same build works fine I Mac OS El Cap and iOS 9.3.5

I thought it was my upgrade to iOS 10 this past week but I’m concluding it’s xCode 8.


#6

And is it a Meteor issue that will get a fix to work with Xcode 8 soon or do we keep trying with Xcode 8 updates whenever they come along?


#7

I’m also having problems with Meteor 1.2 :frowning:

I can run it in the development environment, if I accept to convert Swift 2.3 (there are no changes to my source code required). But as soon as I try to make a production build, an error is thrown. I guess it is because the legacy Swift flag is not being set.

I’ve also got the problem that code signing does not work properly, I always have to set the development team manually. Maybe the build failure is based on this.

Here’s my output:

=> Errors executing Cordova commands:         
                                              
   While building Cordova app for platform iOS:
   Error:                                     
   /Users/waldgeist/Documents/Development/htdocs/jobguzz/webapp/.meteor/local/cordova-build/platforms/ios/cordova/build:
   Command failed with exit code 2 Error output:
   ** BUILD FAILED **
   
   
   The following build commands failed:
   Check dependencies
   (1 failure)
   Error code 65 for command: xcodebuild with args:
   -xcconfig,/Users/waldgeist/Documents/Development/htdocs/jobguzz/webapp/.meteor/local/cordova-build/platforms/ios/cordova/build-release.xcconfig,-project,jobguzz.xcodeproj,ARCHS=i386,-target,jobguzz,-configuration,Release,-sdk,iphonesimulator,build,VALID_ARCHS=i386,CONFIGURATION_BUILD_DIR=/Users/waldgeist/Documents/Development/htdocs/jobguzz/webapp/.meteor/local/cordova-build/platforms/ios/build/emulator,SHARED_PRECOMPS_DIR=/Users/waldgeist/Documents/Development/htdocs/jobguzz/webapp/.meteor/local/cordova-build/platforms/ios/build/sharedpch
   at ChildProcess.whenDone
   (/Users/waldgeist/.meteor/packages/meteor-tool/.1.1.10.195lp5z++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/cordova-lib/src/cordova/superspawn.js:139:23)
   at ChildProcess.emit (events.js:98:17)
   at maybeClose (child_process.js:766:16)
   at Socket.<anonymous> (child_process.js:979:11)
   at Socket.emit (events.js:95:17)
   at Pipe.close (net.js:466:12)

#8

Update: seems as if my build fail is indeed caused by code signing. Here’s a good explanation what has to be fixed in the Xcode project to make things work again:

http://radex.io/xcode7-xcode8/

If I run a dev build and fix the settings manually (i.e. set Swift to legacy version and set the provisioning profile), I can to a prod build afterwards. I am now looking for a way to automate this via a Cordova build script.


#9

The released version of iOS 10 broke my app as well. I just spins in the startup screen. It broke this way with an iOS 9 update earlier this year. Doing a meteor update and recompile fixed it but that will be difficult until Xcode 8 is supported. Had at least one Android update kill the Android version as well and this is not a complicated app.

I like Meteor but the apps sure are brittle.


#10

I just used this and it worked. You just have to convert the code to Swift 3 as Xcode suggests. It will tell you that there is no need to update, then it worked like a charm:-)

meteor add cordova:cordova-plugin-meteor-webapp@https://github.com/meteor/cordova-plugin-meteor-webapp.git#8bf95eed3f313299fc2de33658866278eea2cdc5

link for the updated branch https://github.com/meteor/cordova-plugin-meteor-webapp/tree/swift3


#11

Mine is actually a web app, not a native / Cordova app … but I think the XCode 8 upgrade broke things anyway


#12

Do you get any console error?

I’m getting this error now :

Failed to parse SourceMap: http://local host:3000/packages/3stack:bignumber/bignumber.browserify.js


#13

I’m running the app as a web app. It works on my iOS 9 device but not fully on my iOS 10 device

Any ideas please?