Meteor 1.3 atmosphere package not working

I’m having issues with mizzao:sharejs on 1.3. It appears to not be loading the package. I’ve seen putting the package into a compatibility folder, just not sure how its done.Works fine in 1.2.1.

Uncaught TypeError: Cannot read property ‘extendDoc’ of undefined

mizzao_sharejs.js?hash=7f18169…:130 TypeError: doc.attach_cm is not a function

What do you mean by this? Did you not just add the package with meteor add?

mizzao:sharejs seems to error when adding it via meteor add in 1.3. I’m wondering if there is a way to run packages from 1.2 in 1.3 in some type of compatibility mode.

It should just work, we put a lot of effort into backwards compatibility. It might be worth filing a bug on Meteor, the package, and/or both, if you can make a simple reproduction.

Your error message mentions doc.attach_cm which should only come up if you’re attempting to use the CodeMirror editor. Did you meteor add mizzao:sharejs-codemirror?

I can also confirm the same error briarfox had.
I updated meteor to 1.3 and added the “mizzao:sharejs-codemirror 4.12.0” package and get the same error.
On previous version of meteor, it worked fine.

Anyway quick fix will be to start meteor with downgraded version :slight_smile:

I have the same issue and I’ve been trying to find a work out for a few days.
there is also a bug in the Ace library as soon as you add the package.
the sharejsText Template still works fine but less features are available with it

I’m having the same error message. How do you start meteor with the downgraded version?

meteor --release 1.2.1

I’m pretty new to programming so thanks a lot for your help.