Meteor 1.3 deploy Error with MUP


#1

updated the node version to 0.10.43 and now the app is not being deployed…
Meteor version: 1.3

Started TaskList: Deploy app ‘txtile’ (linux)
[107.170.220.243] - Uploading bundle
[107.170.220.243] - Uploading bundle: SUCCESS
[107.170.220.243] - Setting up Environment Variables
[107.170.220.243] - Setting up Environment Variables: SUCCESS
[107.170.220.243] - Invoking deployment process
[107.170.220.243] x Invoking deployment process: FAILED

-----------------------------------STDERR-----------------------------------
 WARN deprecated on Windows, run them from an Administrator prompt.)
npm WARN deprecated 
npm WARN deprecated If you're running the version of npm bundled with
npm WARN deprecated Node.js 0.10 LTS, be aware that the next version of 0.10 LTS
npm WARN deprecated will be bundled with a version of npm@2, which has some small
npm WARN deprecated backwards-incompatible changes made to `npm run-script` and
npm WARN deprecated semver behavior.
npm WARN package.json meteor-dev-bundle@0.0.0 No description
npm WARN package.json meteor-dev-bundle@0.0.0 No repository field.
npm WARN package.json meteor-dev-bundle@0.0.0 No README data
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0curl: (7) Failed to connect to localhost port 80: Connection refused
Latest deployment failed! Reverted back to the previous version.
-----------------------------------STDOUT-----------------------------------
de`
ansi-regex@0.2.1 node_modules/ansi-regex

ansi-styles@1.1.0 node_modules/ansi-styles

chalk@0.5.1 node_modules/chalk

escape-string-regexp@1.0.5 node_modules/escape-string-regexp

has-ansi@0.1.0 node_modules/has-ansi

strip-ansi@0.3.0 node_modules/strip-ansi

supports-color@0.2.0 node_modules/supports-color

eachline@2.3.3 node_modules/eachline

type-of@2.0.1 node_modules/type-of

amdefine@1.0.0 node_modules/amdefine

asap@2.0.3 node_modules/asap

underscore@1.5.2 node_modules/underscore

meteor-promise@0.5.1 node_modules/meteor-promise

promise@7.0.4 node_modules/promise

source-map-support@0.3.2 node_modules/source-map-support

semver@4.1.0 node_modules/semver

source-map@0.1.32 node_modules/source-map

fibers@1.0.8 node_modules/fibers
Waiting for MongoDB to initialize. (5 minutes)
connected
txtile stop/waiting
txtile start/running, process 23553
Waiting for 120 seconds while app is booting up
Checking is app booted or not?
txtile stop/waiting
txtile start/running, process 23923
----------------------------------------------------------------------------

— MUP logs ----

/opt/txtile/app/programs/server/node_modules/fibers/future.js:267
throw(ex);
^
Error: ENOENT, no such file or directory '/opt/txtile/app/programs/server/npm/node_modules/meteor/ddp-server/node_modules/sockjs/node_modules/faye-websocket/node_modules/websocket-driver/lib/websocket/driver’
at Object.fs.lstatSync (fs.js:691:18)
at Object.realpathSync (fs.js:1279:21)
at tryFile (module.js:142:15)
at tryExtensions (module.js:150:20)
at Function.Module._findPath (module.js:185:20)
at Function.Module._resolveFilename (module.js:336:25)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object. (/opt/txtile/app/programs/server/npm/node_modules/meteor/ddp-server/node_modules/sockjs/node_modules/faye-websocket/node_modules/websocket-driver/lib/websocket/driver.js:9:14)
error: Forever detected script exited with code: 8


#2

It seems that some of files in one of the internal packages in node_modules directory are missing, which is kind of weird. I would try to:

  • re-install Meteor (by removing ~/.meteor directory first and then installing it again)
  • do a meteor reset in your project directory
  • try to deploy again with mup

#3

+1 having the same problem. It was driving me nuts for about 10 hours. I thought i had some faulty code and had to deploy for every single file to check. After i did that i found out its not working anymore because of the Meteor 1.3 Update!

It did work with METEOR@1.3-beta.11 (it still does – i am leaving it on this version for now) but as soon as i update to the 1.3-not-beta-version it wont deploy anymore with the exact message ("error: Forever detected script exited with code: 8)


#4

The issue was new meteor build system i guess
meteor build /path/to/build --architecture os.linux.x86_64

with the beta it was working because we still had Meteor 1.2 build tool and now thats changed i think few edit in mup code will solve it…


#5

I found some useful info on Github and when I was attempting my own upload with mup. It looks like the bcrypt package needs updating to 0.8.5 for it to work. Not sure if this is due to the update to node 0.10.43.

Saying that though, no idea how to update the bcrypt version…


#6

Worked for me:

  1. Connect to your server and cd to your app: cd /opt/your-app/
  2. delete bcrypt rm -rf ./app/programs/server/npm/node_modules/meteor/npm-bcrypt/node_modules/bcrypt
  3. install bcrypt npm install -g bcrypt
  4. copy it into your app: cp -r /usr/lib/node_modules/bcrypt ./app/programs/server/npm/node_modules/meteor/npm-bcrypt/node_modules/

#7

This is annoying if you’re running multiple instances, but thanks!


#8

But what about re-deploying? Won’t that overwrite bcrypt? If so, how do you go about starting your app once you’ve corrected the bcrypt issue?


#10

I had that same issue. It didn’t work for me. I presume because of the overwriting.


#11

It is just a workaround because I needed my app to run again.


#12

How did you get it to work?

If you deploy with MUP, it will rebuild everything including bcrypt, show the bcrypt error, and revert back to the old app.


#13

I added --architecture os.linux.x86_64 to mup, Please try my fork: https://github.com/mscherer82/meteor-up

On Windows:

  1. npm remove -g mup
  2. make sure mup is removed
  3. git clone https://github.com/mscherer82/meteor-up
  4. start cmd as Administrator
  5. cd meteor-up
  6. npm install
  7. npm link

#15

I tried this out in OSX, not working for me.


#16

I had the same problem/error,

I switched to mupx, and followed the migration guide :

https://github.com/arunoda/meteor-up/tree/mupx#migrating-from-meteor-up-0x


#17

I also solved it with mupx.


How do you run Meteor in production?
#18

Just tried mupx on a new Digital Ocean droplet; didn’t work for me :confused:


#19

Can’t use mupx because docker isn’t working on my clients server.


#20

Try to use my mup fork: https://github.com/M4v3R/meteor-up

I also had this issue and this version works fine for me. It also updates mup to install Mongo 3.2 on the server during mup setup so you can use more Mongo features.

I had some issues with PhantomJS installation (bitbucket server returning 403) so I just disabled installing PhantomJS in mup.json.


Deploying to AWS with Meteor 1.3.5 still using MUP
#21

Meteor 1.3.2-rc.5 fixed everything for me. I can deploy with mupx fine now. For good measure I deleted node_modules and .meteor/local before deploying again.


#22

@marc2 's solution worked wonderfully! Thank you!