Meteor 1.3 throws `Tinytest is not defined` error with new app

I just tried out the new 1.3 release by creating a new hello world app and it throws an error:

foo|⇒ meteor run
[[[[[ ~/Projects/sandbox/foo ]]]]]

=> Started proxy.
=> Started MongoDB.
W20160329-11:59:01.786(-7)? (STDERR)
W20160329-11:59:01.786(-7)? (STDERR) /Users/adam/Projects/sandbox/foo/.meteor/local/build/programs/server/boot.js:324
W20160329-11:59:01.787(-7)? (STDERR) }).run();
W20160329-11:59:01.787(-7)? (STDERR)    ^
W20160329-11:59:01.787(-7)? (STDERR) ReferenceError: Tinytest is not defined
W20160329-11:59:01.787(-7)? (STDERR)     at meteorEnv (packages/meteor.js:1388:1)
W20160329-11:59:01.787(-7)? (STDERR)     at Package (packages/meteor.js:1394:4)
W20160329-11:59:01.787(-7)? (STDERR)     at packages/meteor.js:2513:4
W20160329-11:59:01.787(-7)? (STDERR)     at packages/meteor.js:2527:3
W20160329-11:59:01.787(-7)? (STDERR)     at /Users/adam/Projects/sandbox/foo/.meteor/local/build/programs/server/boot.js:283:10
W20160329-11:59:01.787(-7)? (STDERR)     at Array.forEach (native)
W20160329-11:59:01.787(-7)? (STDERR)     at Function._.each._.forEach (/Users/adam/.meteor/packages/meteor-tool/.1.3.0_3.1kyr7c7++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/server-lib/node_modules/underscore/underscore.js:79:11)
W20160329-11:59:01.787(-7)? (STDERR)     at /Users/adam/Projects/sandbox/foo/.meteor/local/build/programs/server/boot.js:133:5
=> Exited with code: 8

Any ideas on how to get around this? I’ve also tried removing all code in the main.js files but it still throws the same error.

1 Like

Me too. Totally vanilla app… just “meteor create myapp” and then “meteor” and I get this.

Must be some issue with the updater. I tried installing using “curl | sh” . It removed my old meteor install and put the new one in and no more problems.

1 Like

Thanks @foobarbecue that worked I just ran rm -Rf ~/.meteor before and then ran curl. Working now!

This also worked for me – I’m on OSX El Capitan.

I now get this error when I try to deploy a Meteor 1.2.1 app using the install script

I think this error is preventing the app from starting.