Meteor 1.4.1.1: "apollo-server@0.2.4 requires a peer of graphql"


#1

I just upgraded to 1.4.1.1 and got a message suggesting I run:

meteor npm install --save bcrypt

So I did, and then got the following result:

Nova@0.0.0 /Users/sacha/Dev/Telescope
├─┬ bcrypt@0.8.7
│ ├── bindings@1.2.1
│ └── nan@2.3.5
└── UNMET PEER DEPENDENCY graphql@^0.6.1

npm WARN apollo-server@0.2.4 requires a peer of graphql@^0.6.1 but none was installed.

I don’t use Apollo in my app though… Does 1.4.1.1 introduce some kind of new Apollo dependency?


#2

Not sure how related it is but I’ve started to have build problems with an npm dependency too.

Error: Can't find npm module 'body-parser'. Did you forget to call 'Npm.depends' in package.js within the 'modules-runtime' package?

Complete show stopper, broke our staging env.

Please advice


#3

What if you add body-parser to your package.json?

BTW my Apollo issue isn’t really affecting anything, I just thought it was a weird message to get out of the blue.


#4

@sacha is already added:

... "dependencies": { "body-parser": "^1.15.2", "meteor-node-stubs": "~0.2.0" } }

That’s why I’m feeling lost. The npm install after the build runs too and the issue persists. So at some point the build must be creating the dependencies wrong but I don’t know where to look at to see what causes it or what workaround we might have


#5

@sacha are you sure you didn’t add apollo to this app? Because I’m 110% sure there are exactly no traces of Apollo in any release of Meteor.


#6

@sacha are you sure you didn’t add apollo to this app? Because I’m 110% sure there are exactly no traces of Apollo in any release of Meteor.


#7

Apparently these were “extraneous” packages, so I ran npm prune to remove them. I still don’t know how they got in there… Man, I miss the Meteor package manager sometimes :wink:


#8

I feel like with NPM it’s a good idea to just delete all of node_modules and reinstall once in a while.