Meteor 1.4.1.1 Build Cannot find module fibers after following https://guide.meteor.com/deployment.html#custom-deployment


#1

I’ve been searching all over for a resolution to my issue. I haven’t found anything that helps me get this up and running again. I had my app deployed to an OS X server and it was working fine. I went to update my app last night with a new branch, I was able to build the app, I ran npm install in bundle/programs/server, I am not able to run my app now as it states that it can’t find the module fibers:

Error: Cannot find module 'fibers’
at Function.Module._resolveFilename (module.js:325:15)
at Function.Module._load (module.js:276:25)
at Function._load (/usr/local/lib/node_modules/pm2/node_modules/pmx/lib/transaction.js:62:21)
at Module.require (module.js:353:17)
at require (internal/module.js:12:17)
at Object. (/Users/shelter/bundle/programs/server/boot.js:1:75)
at Module._compile (module.js:409:26)
at Object.Module._extensions…js (module.js:416:10)
at Module.load (module.js:343:32)
at Function.Module._load (module.js:300:12)

When I run npm install, this is the output:

╰─➤ npm install
npm WARN package.json meteor-dev-bundle@0.0.0 No description
npm WARN package.json meteor-dev-bundle@0.0.0 No repository field.
npm WARN package.json meteor-dev-bundle@0.0.0 No README data
\

fibers@1.0.13 install /Users/shelter/bundle/programs/server/node_modules/fibers
node build.js || nodejs build.js

darwin-x64-v8-4.5 exists; testing
Binary is fine; exiting

meteor-dev-bundle@0.0.0 install /Users/shelter/bundle/programs/server
node npm-rebuild.js

bcrypt@0.8.7 install /Users/shelter/bundle/programs/server/npm/node_modules/bcrypt
node-gyp rebuild

CXX(target) Release/obj.target/bcrypt_lib/src/blowfish.o
CXX(target) Release/obj.target/bcrypt_lib/src/bcrypt.o
CXX(target) Release/obj.target/bcrypt_lib/src/bcrypt_node.o
SOLINK_MODULE(target) Release/bcrypt_lib.node

fibers@1.0.14 install /Users/shelter/bundle/programs/server/npm/node_modules/fibers
node build.js || nodejs build.js

darwin-x64-v8-4.5 exists; testing
Binary is fine; exiting
bcrypt@0.8.7 /Users/shelter/bundle/programs/server/npm/node_modules/bcrypt
bindings@1.2.1 /Users/shelter/bundle/programs/server/npm/node_modules/bindings
nan@2.3.5 /Users/shelter/bundle/programs/server/npm/node_modules/nan
fibers@1.0.14 /Users/shelter/bundle/programs/server/npm/node_modules/fibers
{
“meteor-dev-bundle”: “0.0.0”,
“npm”: “2.15.9”,
“ares”: “1.10.1-DEV”,
“http_parser”: “2.7.0”,
“icu”: “56.1”,
“modules”: “46”,
“node”: “4.5.0”,
“openssl”: “1.0.2h”,
“uv”: “1.9.1”,
“v8”: “4.5.103.37”,
“zlib”: “1.2.8”
}
amdefine@1.0.0 node_modules/amdefine

underscore@1.5.2 node_modules/underscore

meteor-promise@0.7.2 node_modules/meteor-promise

asap@2.0.4 node_modules/asap

semver@4.1.0 node_modules/semver

eachline@2.3.3 node_modules/eachline
└── type-of@2.0.1

source-map-support@0.3.2 node_modules/source-map-support

chalk@0.5.1 node_modules/chalk
├── ansi-styles@1.1.0
├── escape-string-regexp@1.0.5
├── supports-color@0.2.0
├── strip-ansi@0.3.0 (ansi-regex@0.2.1)
└── has-ansi@0.1.0 (ansi-regex@0.2.1)

source-map@0.1.32 node_modules/source-map

promise@7.1.1 node_modules/promise

fibers@1.0.13 node_modules/fibers

When I try to run the main.js I don’t get any errors. The only way I’ve been able to see the error output is by running it in pm2(pm2 start bundle/main.js). Not sure what else to do to get this up and running. I’ve rebuilt the app, reinstalled npm, tried Node 4.4.7, 5.0, and checked multiple threads on people who have had issues with not getting fibers to install properly. The last time that I deployed I ran into a bunch of issues deploying manually as well, but ultimately was able to get it up and running. I’m not able to do it this time. Any help you guys could give would be greatly appreciated as I’m currently spinning my wheels.


#2

Did you ever get this one solved?

I’m new to Meteor development and am experiencing the same “Error: Cannot find module ‘fibers’” locally. I went through several threads online trying to find a solution but have been unsuccessful so far.

Currently reinstalling Node and Meteor.


#3

After updating to meteor version 1.4.2 and following the steps in the included readme I haven’t had any issues. I don’t remember exactly how I got this up and running for 1.4.1.1, but I did. It took a long time and there isn’t any way for me to remember exactly what steps I took that fixed it. But since I’ve been using 1.4.2 I haven’t had a problem.


#4

@ajhostetler

Thanks for your response!

The error went away for me after I reinstalled Meteor.