Meteor 1.4 build error


#1

Hi,

I would like build my Meteor 1.4 APP but i’ve error.

meteor build ../build

Return :

Errors prevented bundling:
While minifying app code:
C:\Users\str\AppData\Local.meteor\packages\standard-minifier-js\1.1.8\plugin.minifyStdJS.os\npm\node_modules\meteor\minifier-js\node_modules\uglify-js\lib\parse.js:196:18: Unexpected character '`'
at new JS_Parse_Error (C:\Users\str\AppData\Local.meteor\packages\standard-minifier-js\1.1.8\plugin.minifyStdJS.os\npm\node_modules\meteor\minifier-js\node_modules\uglify-js\lib\parse.js:196:18)
at js_error (C:\Users\str\AppData\Local.meteor\packages\standard-minifier-js\1.1.8\plugin.minifyStdJS.os\npm\node_modules\meteor\minifier-js\node_modules\uglify-js\lib\parse.js:204:11)
at parse_error (C:\Users\str\AppData\Local.meteor\packages\standard-minifier-js\1.1.8\plugin.minifyStdJS.os\npm\node_modules\meteor\minifier-js\node_modules\uglify-js\lib\parse.js:314:9)
at Object.next_token (C:\Users\str\AppData\Local.meteor\packages\standard-minifier-js\1.1.8\plugin.minifyStdJS.os\npm\node_modules\meteor\minifier-js\node_modules\uglify-js\lib\parse.js:562:9)
at next (C:\Users\str\AppData\Local.meteor\packages\standard-minifier-js\1.1.8\plugin.minifyStdJS.os\npm\node_modules\meteor\minifier-js\node_modules\uglify-js\lib\parse.js:661:25)
at subscripts (C:\Users\str\AppData\Local.meteor\packages\standard-minifier-js\1.1.8\plugin.minifyStdJS.os\npm\node_modules\meteor\minifier-js\node_modules\uglify-js\lib\parse.js:1337:13)
at subscripts (C:\Users\str\AppData\Local.meteor\packages\standard-minifier-js\1.1.8\plugin.minifyStdJS.os\npm\node_modules\meteor\minifier-js\node_modules\uglify-js\lib\parse.js:1318:20)
at subscripts (C:\Users\str\AppData\Local.meteor\packages\standard-minifier-js\1.1.8\plugin.minifyStdJS.os\npm\node_modules\meteor\minifier-js\node_modules\uglify-js\lib\parse.js:1318:20)
at expr_atom (C:\Users\str\AppData\Local.meteor\packages\standard-minifier-js\1.1.8\plugin.minifyStdJS.os\npm\node_modules\meteor\minifier-js\node_modules\uglify-js\lib\parse.js:1194:20)
at maybe_unary (C:\Users\str\AppData\Local.meteor\packages\standard-minifier-js\1.1.8\plugin.minifyStdJS.os\npm\node_modules\meteor\minifier-js\node_modules\uglify-js\lib\parse.js:1358:19)

I’m Windows user, i’ve same error with W7 and W10.

Any idea about this error ?

Thank you community !


#2

This is currently being looked into here:


#3

Hi @hwillson

No fix is available for the moment ?

EDIT : I’ve install the patch 1.4.0.1, but no result. Same problem for build.


#4

Any news about this bug ?